Closed Bug 1454799 Opened 4 years ago Closed 4 years ago

Intermittent /eventsource/dedicated-worker/eventsource-constructor-non-same-origin.htm | 'object' object is not iterable

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1455057

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=174190824&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/eNtMjkr4ReWdeIamqYn20Q/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-17T20:36:31.175Z] 20:36:31     INFO - PID 4343 | Assertion failure: ((bool)(__builtin_expect(!!(!NS_FAILED_impl(rv)), 1))), at /builds/worker/workspace/build/src/dom/base/EventSource.cpp:1334
[task 2018-04-17T20:36:31.184Z] 20:36:31     INFO - PID 4343 | #01: mozilla::dom::EventSourceImpl::DispatchFailConnection() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.187Z] 20:36:31     INFO - PID 4343 | #02: mozilla::dom::EventSourceImpl::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.188Z] 20:36:31     INFO - .
[task 2018-04-17T20:36:31.189Z] 20:36:31     INFO - TEST-OK | /eventsource/dedicated-worker/eventsource-close2.htm | took 1521ms
[task 2018-04-17T20:36:31.189Z] 20:36:31     INFO - TEST-START | /eventsource/dedicated-worker/eventsource-constructor-non-same-origin.htm
[task 2018-04-17T20:36:31.192Z] 20:36:31     INFO - PID 4343 | #03: nsCORSListenerProxy::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.196Z] 20:36:31     INFO - PID 4343 | #04: mozilla::net::nsHttpChannel::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.199Z] 20:36:31     INFO - PID 4343 | #05: nsInputStreamPump::OnStateStop() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.207Z] 20:36:31     INFO - PID 4343 | #06: nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.209Z] 20:36:31     INFO - PID 4343 | #07: nsInputStreamReadyEvent::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.210Z] 20:36:31     INFO - PID 4343 | #08: nsThread::ProcessNextEvent(bool, bool*) [clone .part.291] (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.211Z] 20:36:31     INFO - PID 4343 | #09: NS_ProcessNextEvent(nsIThread*, bool) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.212Z] 20:36:31     INFO - PID 4343 | #10: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.212Z] 20:36:31     INFO - PID 4343 | #11: MessageLoop::RunInternal() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.213Z] 20:36:31     INFO - PID 4343 | #12: MessageLoop::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.214Z] 20:36:31     INFO - PID 4343 | #13: nsBaseAppShell::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.217Z] 20:36:31     INFO - PID 4343 | #14: nsAppStartup::Run() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.217Z] 20:36:31     INFO - PID 4343 | #15: XREMain::XRE_mainRun() (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.218Z] 20:36:31     INFO - PID 4343 | #16: XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.218Z] 20:36:31     INFO - PID 4343 | #17: XRE_main(int, char**, mozilla::BootstrapConfig const&) (/builds/worker/workspace/build/application/firefox/libxul.so)
[task 2018-04-17T20:36:31.219Z] 20:36:31     INFO - PID 4343 | #18: do_main(int, char**, char**) (/builds/worker/workspace/build/application/firefox/firefox)
[task 2018-04-17T20:36:31.219Z] 20:36:31     INFO - PID 4343 | #19: main (/builds/worker/workspace/build/application/firefox/firefox)
[task 2018-04-17T20:36:31.219Z] 20:36:31     INFO - PID 4343 | ExceptionHandler::GenerateDump cloned child 4434
[task 2018-04-17T20:36:31.219Z] 20:36:31     INFO - PID 4343 | ExceptionHandler::SendContinueSignalToChild sent continue signal to child
[task 2018-04-17T20:36:31.219Z] 20:36:31     INFO - PID 4343 | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[task 2018-04-17T20:36:31.482Z] 20:36:31    ERROR - Lost marionette connection before starting test
[task 2018-04-17T20:36:31.486Z] 20:36:31  WARNING - Traceback (most recent call last):
[task 2018-04-17T20:36:31.486Z] 20:36:31  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/base.py", line 157, in run_test
[task 2018-04-17T20:36:31.487Z] 20:36:31  WARNING -     result = self.do_test(test)
[task 2018-04-17T20:36:31.487Z] 20:36:31  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 523, in do_test
[task 2018-04-17T20:36:31.487Z] 20:36:31  WARNING -     timeout).run()
[task 2018-04-17T20:36:31.487Z] 20:36:31  WARNING - TypeError: 'object' object is not iterable
[task 2018-04-17T20:36:31.488Z] 20:36:31  WARNING - 
[task 2018-04-17T20:36:31.489Z] 20:36:31     INFO - TEST-UNEXPECTED-ERROR | /eventsource/dedicated-worker/eventsource-constructor-non-same-origin.htm | 'object' object is not iterable
[task 2018-04-17T20:36:31.489Z] 20:36:31     INFO - Traceback (most recent call last):
[task 2018-04-17T20:36:31.489Z] 20:36:31     INFO -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/base.py", line 157, in run_test
[task 2018-04-17T20:36:31.489Z] 20:36:31     INFO -     result = self.do_test(test)
[task 2018-04-17T20:36:31.489Z] 20:36:31     INFO -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 523, in do_test
[task 2018-04-17T20:36:31.489Z] 20:36:31     INFO -     timeout).run()
[task 2018-04-17T20:36:31.490Z] 20:36:31     INFO - TypeError: 'object' object is not iterable
[task 2018-04-17T20:36:31.490Z] 20:36:31     INFO - TEST-INFO took 293ms
[task 2018-04-17T20:36:31.498Z] 20:36:31     INFO - Browser exited with return code 11
Hi! Looks like this fail was introduced with this push: https://is.gd/nmpJE3 
This fails mostly on debug-web-platform-tests-12 W(wpt12) and there's another fail that began also with this push that happens on e-10s https://is.gd/hb9QU1, see bug 1454800. 

Andrea could take a look at these two failures?
Flags: needinfo?(amarchesini)
See Also: → 1454800
It seems a dup of bug 1455057.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1455057
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.