Closed Bug 1454800 Opened 4 years ago Closed 4 years ago

Intermittent /eventsource/dedicated-worker/eventsource-constructor-non-same-origin.htm | pop from empty list

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1455057

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:product])

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=174190844&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/IeDncrqcRxCIVewbte9wOA/runs/0/artifacts/public/logs/live_backing.log

task 2018-04-17T20:40:38.826Z] 20:40:38  WARNING - Traceback (most recent call last):
[task 2018-04-17T20:40:38.827Z] 20:40:38  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 464, in _run
[task 2018-04-17T20:40:38.827Z] 20:40:38  WARNING -     self.result = True, self.func(self.protocol, self.url, self.timeout)
[task 2018-04-17T20:40:38.827Z] 20:40:38  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 531, in do_testharness
[task 2018-04-17T20:40:38.828Z] 20:40:38  WARNING -     parent_window = protocol.testharness.close_old_windows(protocol)
[task 2018-04-17T20:40:38.828Z] 20:40:38  WARNING -   File "/builds/worker/workspace/build/tests/web-platform/tests/tools/wptrunner/wptrunner/executors/executormarionette.py", line 151, in close_old_windows
[task 2018-04-17T20:40:38.828Z] 20:40:38  WARNING -     runner_handle = handles.pop(0)
[task 2018-04-17T20:40:38.829Z] 20:40:38  WARNING - IndexError: pop from empty list
[task 2018-04-17T20:40:38.829Z] 20:40:38  WARNING - 
[task 2018-04-17T20:40:38.870Z] 20:40:38     INFO - PID 5431 | [Parent 5431, Main Thread] WARNING: unable to post continuation event: file /builds/worker/workspace/build/src/xpcom/io/nsStreamUtils.cpp, line 490
[task 2018-04-17T20:40:38.872Z] 20:40:38     INFO - TEST-UNEXPECTED-ERROR | /eventsource/dedicated-worker/eventsource-constructor-non-same-origin.htm | pop from empty list
[task 2018-04-17T20:40:38.873Z] 20:40:38     INFO - TEST-INFO took 1434ms
Duplicate of this bug: 1455180
See Also: → 1454799
This started with this push https://is.gd/gLPGXA and happens only on e-10s. It started alongside bug 1454799.
Flags: needinfo?(amarchesini)
Sorry, this is the exact push https://is.gd/4ROxVP. From 20 jobs this fails around 5 times on Linux Debug and around 2-3 times on Linux QR.
Also this one seems fix with patch for bug 1455057.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1455057
Whiteboard: [stockwell needswork:owner] → [stockwell fixed:product]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.