Closed Bug 1454833 Opened 2 years ago Closed 2 years ago

Keyboard shortcuts do not work on hangouts.google.com in strict keypress event dipatching mode

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: imyxhuang, Assigned: masayuki)

References

Details

(Keywords: site-compat)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180416133911

Steps to reproduce:

1. Download Nightly version 61.0a1.en-linux-x86-64 from the Mozilla site or install via firefox-trunk PPA, on Ubuntu 17.10.
2. Sign in to https://mail.google.com/mail/u/0/#inbox


Actual results:

None of Gmail's keyboard shortcuts work, including "c" to compose a new email, "/" to search, and shortcuts such as Ctrl+B in the Hangouts windows below merely activate Firefox's shortcuts to view the bookmarks sidebar, etc.


Expected results:

https://drive.google.com/drive/my-drive seems to have shortcuts working properly. For example, "j" and "k" can select folders down and up.
(In reply to imyxhuang from comment #0)
> Actual results:
> 
> None of Gmail's keyboard shortcuts work, including "c" to compose a new
> email, "/" to search, and shortcuts such as Ctrl+B in the Hangouts windows
> below merely activate Firefox's shortcuts to view the bookmarks sidebar, etc.

Ah, I need to turn on keyboard shortcut in Gmail settings to use those shortcut keys.

However, I don't reproduce about "c", "/". I reproduced only Ctrl+B on Hanguots window since it's a sub-document loaded from hangouts.google.com.

Are you sure to reproduce the former issue? How about in safe mode?
Flags: needinfo?(imyxhuang)
Oh, I'm silly, I didn't turn on shortcut keys either. I assumed it was all of Gmail but only noticed it because of Hangouts. I think I'll close this bug and add a comment to bug 1440189 regarding Hangouts (since that should be a quick fix), unless you have a better idea to tidy this up.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(imyxhuang)
Resolution: --- → INVALID
No, we should add hangouts.google.com to the blacklist from this bug.
Assignee: nobody → masayuki
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Status: REOPENED → ASSIGNED
Component: Untriaged → DOM: Events
Product: Firefox → Core
Blocks: 1440189
Summary: Keyboard shortcuts do not work on mail.google.com, despite commit 2ab582bacc98 → Keyboard shortcuts do not work on hangouts.google.com in strict keypress event dipatching mode
Comment on attachment 8968825 [details]
Bug 1454833 - Allow to use legacy keypress event behavior in hangouts.google.com

https://reviewboard.mozilla.org/r/237556/#review244550
Attachment #8968825 - Flags: review?(bugs) → review+
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/f63f20404c55
Allow to use legacy keypress event behavior in hangouts.google.com r=smaug
https://hg.mozilla.org/mozilla-central/rev/f63f20404c55
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.