Closed Bug 1454880 Opened Last year Closed Last year

UI DeveloperTools Network Tab, when Request Details is on, Pushes Cause and Domain together and make them indistinguishable

Categories

(DevTools :: Netmonitor, enhancement, P3)

60 Branch
enhancement

Tracking

(firefox60 wontfix, firefox61 wontfix, firefox62 wontfix, firefox63 fixed)

RESOLVED FIXED
Firefox 63
Tracking Status
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- fixed

People

(Reporter: me, Assigned: amychan331, Mentored)

Details

(Keywords: good-first-bug, Whiteboard: good-first-bug)

Attachments

(3 files)

Attached image request-detail-on.jpeg
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180409184545

Steps to reproduce:

Go to Developer Tools, Network Tab, Open a page and see the log. Click on Show Request Detail.


Actual results:

The right side of the Tab shrinks, domain and cause connect together and it is hard to distinguish them from each other. (See Attachment)


Expected results:

There should be a small distinguishable distance between these two.
Attached image request-detail-off.jpeg
Summary: UI DevelperTools Network Tab, when Request Details is on Pushes to Cause and Domain together and make them indistinguishable → UI DevelperTools Network Tab, when Request Details is on, Pushes Cause and Domain together and make them indistinguishable
I have tested this report on Windows 10 using latest Nightly, DevEdition and Fx release builds. I can see the mentioned behavior when clicking on Show Request Details. The displayed network tab is shrunk and is hard to distinguish between the Domain and Cause column. It would be great if the user has an option to edit the size of the column or at least there is a line making the distinguishing easier.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Netmonitor
Ever confirmed: true
Mentor: odvarko
Keywords: good-first-bug
Priority: -- → P3
Whiteboard: good-first-bug
Can I work with this one? Would this be something similar to the grey vertical lines after the Size column?
So, I started by adding a light grey border at the left side of Cause column. To make the Domain column easier to read when the request detail's panel expands and shrinks all the other columns, I also added a min-width for the Domain column. Don't know if other people would find it strange that only border between Domain and Cause column have a line though...
(In reply to Stefan [:StefanG_QA] from comment #2)
> It would be great if the user has an option to edit the size of the column or at least there is a line making the distinguishing easier.

Yeah, this is one of the most requested and missing feature related to Network panel UX.
We have meta bug 1463423 for this.
Assignee: nobody → amy_yyc
Comment on attachment 8979012 [details]
Bug 1454880 - Make the Domain and Cause column more readable

https://reviewboard.mozilla.org/r/245282/#review251842

Thanks for looking into this!

Please see my inline comment.

Honza

::: devtools/client/netmonitor/src/assets/styles/RequestList.css:401
(Diff revision 1)
>  .requests-list-cause {
>    min-width: 75px;
>  }
>  
> +.request-list-item .requests-list-cause.requests-list-column {
> +  border-left: 1px solid var(--grey-30);

Please remove the border, the padding itself should be already good step forward.
Attachment #8979012 - Flags: review?(odvarko)
Summary: UI DevelperTools Network Tab, when Request Details is on, Pushes Cause and Domain together and make them indistinguishable → UI DeveloperTools Network Tab, when Request Details is on, Pushes Cause and Domain together and make them indistinguishable
Comment on attachment 8979012 [details]
Bug 1454880 - Make the Domain and Cause column more readable

https://reviewboard.mozilla.org/r/245282/#review251842

> Please remove the border, the padding itself should be already good step forward.

The border has been removed
Comment on attachment 8979012 [details]
Bug 1454880 - Make the Domain and Cause column more readable

https://reviewboard.mozilla.org/r/245282/#review256150

Looks good to me, thanks for the help!

R+

Honza
Attachment #8979012 - Flags: review?(odvarko) → review+
Product: Firefox → DevTools
Hi, is this bug open still open or unresolved? Because I'd like to work on this as my first bug. 

Thank you!
Flags: needinfo?(odvarko)
I didn't realized this still have a New status! I thought it was resolved with my last push. Am I supposed to do anything to turn it to Fixed status, or is there anything else that Hemakshi can work on in this bug? I have only done 2 bugs fixes, so I am still a bit confused about the process in Bugzilla. Sorry if I caused any confusion!
(In reply to Amy Chan from comment #12)
> I didn't realized this still have a New status! I thought it was resolved
> with my last push. Am I supposed to do anything to turn it to Fixed status,
> or is there anything else that Hemakshi can work on in this bug? I have only
> done 2 bugs fixes, so I am still a bit confused about the process in
> Bugzilla. Sorry if I caused any confusion!
Ah, yes. You need to set `checkin-needed` keyword.

1) Click the blue 'Edit Bug' button at the top
2) See Tracking->Keywords field and put new 'checkin-needed' keyword in it (keywords are comma separated)
3) Press 'Save Changes'

And the sheriff will commit the patch for you.

Since it's been a while you should try to apply the patch on the current (repo) HEAD locally - to make sure there are no conflicts.

Honza
Flags: needinfo?(odvarko)
Keywords: checkin-needed
I apply the patch locally on the current head, and it seems to work the same, so I have added the 'checkin-needed'. Thank you!
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/f97e87302374
Make the Domain and Cause column more readable r=Honza
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f97e87302374
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Flags: qe-verify+
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.