crash going to next unread folder? [@ RuleProcessorData::RuleProcessorData() ]

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: basic, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Not sure exactly what is causing this, but the crash seems to happen whenever
I go to a folder that I've not read messages from in that session via that next
unread folder popup (usually triggered by pressing spacebar at the end of a
message/mail in a folder with no unread messages).

TB6417986M
TB6417981Q
TB6416600H
TB6390943W
TB6390902H
TB6390849Q
TB6390431H
TB6390410W
TB6390345W
TB6373009X

Comment 1

16 years ago
It this when going from any folder to any folder, or is it a specific navigation
that's causing a problem? What kind of account are you navigating from/to? Any
special content in the message(s) in the destination folder/group?
QA Contact: olgam → laurel

Comment 2

16 years ago
And what build are you using?

Comment 3

16 years ago
Created attachment 84292 [details]
talkback 6417986

All talkbacks similar
(Reporter)

Comment 4

16 years ago
sorry forgot build ID
2002051807 trunk linux installer sea

ok, the steps I repro this bug:
1. download mail from pop server
2. click on a folder with unread mail
3. (read mail)/(press spacebar) until all mail is read in that folder
4. an OK/Cancel popup box is seen
5. click OK (or press spacebar)
crash....
(Reporter)

Updated

16 years ago
Keywords: crash

Comment 5

16 years ago
So it's taking you to another POP folder on the same account? Or are you
crossing to another account?

Can you open said (next) folder and read the first couple unread messages
without using navigation?

Comment 6

16 years ago
*** Bug 146155 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Mozilla 1.0rc2 gave me similar crashes:

TB 6360243X - moving to next message within a single POP account (with all
plaintext messages).
TB6421715G TB6444502W - similar in secnews.netscape.com - all messages in one group.

Occured after reading a dozen or more messages in the folder / group - did not
involve moving to a new folder / group (as per bug 118014). 

Comment 8

16 years ago
Bug 139556 was a spinoff of bug 118014. Both bug 118014 and this bug have
crashes in MailNews when moving to next folder. Both have talkbacks showing the
problem at RuleProcessorData::RuleProcessorData()

This doesn't look like 118014 is back - but there have been recent checkins in
bug 139556, and I wonder if DougT assignee for that bug add comment if there may
be any association between 139556 and the return of crashes on going to next
unread folder at RuleProcessorData::RuleProcessorData()
(Reporter)

Comment 9

16 years ago
with build 2002052908 linux sea trunk, I don't see the crash anymore. Will test
another build tomorrow.
(Reporter)

Comment 10

16 years ago
with build 2002052908 & 2002053121 linux sea trunk, I don't see the crash anymore.  
But seems like the message does not get displayed after step 5 from comment #4

re: comment #5
> So it's taking you to another POP folder on the same account? Or are you
crossing to another account?

Same account

> Can you open said (next) folder and read the first couple unread messages
without using navigation?
if I do not see the popup box in step 4 I don't see a crash
(Reporter)

Comment 11

15 years ago
ok, I'm no longer seeing this bug, but I'm also no longer using pop mail (using
imap now). Should this be wfm? or..?

Comment 12

14 years ago
This doesn't happen with Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7)
Gecko/20040616 anymore

Updated

14 years ago
Summary: crash going to next unread folder? → crash going to next unread folder? [@ RuleProcessorData::RuleProcessorData() ]
Product: Browser → Seamonkey
(Reporter)

Comment 13

14 years ago
ok marking wfm since it wfm for a long time now (and no one has mention being
able to reproduce it recently)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ RuleProcessorData::RuleProcessorData() ]
You need to log in before you can comment on or make changes to this bug.