Closed Bug 1454954 Opened 2 years ago Closed 2 years ago

Stopped animations cannot be resumed

Categories

(DevTools :: Inspector: Animations, defect)

61 Branch
defect
Not set

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61- disabled, firefox62 verified)

VERIFIED FIXED
Firefox 62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 - disabled
firefox62 --- verified

People

(Reporter: gyula.palko, Assigned: daisuke)

References

(Blocks 2 open bugs)

Details

(Keywords: regression)

Attachments

(2 files)

[Environment:]
Windows 10,
Nightly 61.0a1 2018-04-17

[Steps:]
1. Open Firefox Nightly and load https://rawgit.com/dadaa/3b73f847427025b51ba1ab7333013d0c/raw/77f3f0bb884875a179c3407f73bf8a8dd54751c9/doc_simple_animation.html.
2. Press F12.
3. Select Inspector and Animations panel.
4. Select "ball delayed" node in Inspector
5. Wait for the animation to be finished
6. On Animations panel click the Play/Resume button

[Actual Result:]
The animation is not running, the scrubber remains displayed at the end of the animation bar.

[Expected Result:]
6. The animation should run again from the start
Blocks: 1399830
The Reactified Animation Inspector was pushed to 62. No need to track for 61 anymore.
Thank you for the reporting and I'm sorry for delay.
This behavior is same to previous animation inspector. So, please let me remove this bug from the blocker.
No longer blocks: 1399830
I just tried this out with the old and new animation inspector and it seems to me like this behavior has changed. Re-instating this as a blocker on bug 1399830.
Blocks: 1399830
Oh, I'm so sorry!!
I may have compared with a new one..
Anyway, I'll fix this one, thanks!
Assignee: nobody → dakatsuka
Comment on attachment 8979470 [details]
Bug 1454954 - Part 1: Rewind animations if the currentTime is over endTime when click play button.

https://reviewboard.mozilla.org/r/245636/#review252518

I wonder why this is done actor-side? To me, the methods of the actor represent a low level API that tools can use to interact with things on the page (dom elements, animations, styles, scripts, ...). However it's the tools themselves that decide of the behavior when things in the UI are used by users. So my immediate reaction would be to check for this on the UI-side, and then call the right methods to set the time and resume the animations, rather than moving the logic actor-side.
Moving it actor-side means that it makes it impossible for another client of the protocol to just play the animation without changing its current time (if that's ever needed).
What do you think?
Attachment #8979470 - Flags: review?(pbrosset)
Comment on attachment 8979471 [details]
Bug 1454954 - Part 2: Test the animation state in case of the currentTime is over endTime.

https://reviewboard.mozilla.org/r/245638/#review252522
Attachment #8979471 - Flags: review?(pbrosset) → review+
Comment on attachment 8979470 [details]
Bug 1454954 - Part 1: Rewind animations if the currentTime is over endTime when click play button.

https://reviewboard.mozilla.org/r/245636/#review252518

Thanks, yeah I agree.
Comment on attachment 8979470 [details]
Bug 1454954 - Part 1: Rewind animations if the currentTime is over endTime when click play button.

https://reviewboard.mozilla.org/r/245636/#review252822

Looks great.
Attachment #8979470 - Flags: review?(pbrosset) → review+
Thanks Patrick.
Will land these patches if the try was green.
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c85d74d675c3
Part 1: Rewind animations if the currentTime is over endTime when click play button. r=pbro
https://hg.mozilla.org/integration/autoland/rev/96d23f930840
Part 2: Test the animation state in case of the currentTime is over endTime. r=pbro
https://hg.mozilla.org/mozilla-central/rev/c85d74d675c3
https://hg.mozilla.org/mozilla-central/rev/96d23f930840
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Verified as fixed in Nightly 62.0a1(20180528220216). The issue is not reproducing, stopped animations can be resumed.
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.