Cleanup some private methods in WorkerPrivate.h

RESOLVED FIXED in Firefox 61

Status

()

enhancement
P2
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: baku, Assigned: baku)

Tracking

58 Branch
mozilla61
Points:
---

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(1 attachment)

There are no reasons to have NotifyPrivate() and PostMessageToParentInternal().
Posted patch cleanup.patchSplinter Review
Attachment #8968968 - Flags: review?(bugmail)
Priority: -- → P2
Comment on attachment 8968968 [details] [diff] [review]
cleanup.patch

Review of attachment 8968968 [details] [diff] [review]:
-----------------------------------------------------------------

Restating: Bug 1435263 got rid of the separate WorkerPrivateParent<WorkerPrivate> class which provided a logically distinct "class for parent-thread exposed stuff" and accordingly resulted in some redirection.  These changes are leftover cleanup from that bug.

PS: Good cleanup/thanks for the cleanup!
Attachment #8968968 - Flags: review?(bugmail) → review+
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1c46524d2fbf
Cleanup some private methods in WorkerPrivate.h, r=asuth
https://hg.mozilla.org/mozilla-central/rev/1c46524d2fbf
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Duplicate of this bug: 1454483
You need to log in before you can comment on or make changes to this bug.