Mozilla makes keyboard unusable on Japanese Windows 98

RESOLVED INVALID

Status

()

Core
Internationalization
--
major
RESOLVED INVALID
16 years ago
12 years ago

People

(Reporter: Ryjek, Assigned: Jungshik Shin)

Tracking

({intl})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla 1.0rc2 on Japanese Windows 98 once started, causes other applications to
generate a protection fault each time a key is pressed or released. The
protection fault does not cause the other applications to abort, but each key
press is followed by a system error dialog, which has to be dismissed with a
mouse (because using keyboard pops up more error dialogs). As a result the whole
system except Mozilla becomes unusable, and the only cure is to reboot the computer.

The bug is present regardless of the chosen keyboard, changing keyboard to
English does not help.

This bug was introduced somewhere between 0.9.9 and 1.0rc1. I also
remember having problems like this in ancient versions (like M18 etc.).

I am using Mozilla 1.0rc2 build id 2002020406, but I could see the same problem
in Mozilla 1.0rc1. Mozilla 0.9.9 was working fine.

OS is Japanese Windows 98 4.10.1998, with IME 6.00.41.
no problem with non-Japanese win98 systems

-> Int
Assignee: Matti → yokoyama
Component: Browser-General → Internationalization
QA Contact: imajes-qa → ruixu

Comment 2

16 years ago
ruixu: can you confirm this?  I don't have Win98J.  this is terrible.

Comment 3

16 years ago
Reporter:
It is not reproducible with the latest mozilla build (1.0rc3) on my JA Windows98 SE, could you please try the latest one on your system? Thanks!
Keywords: intl
(Reporter)

Comment 4

16 years ago
I uninstalled my 0.9.8, installed the snapshot and everything was fine. No more
errors.

Then I uninstalled the snapshot, installed 1.0rc2, no errors. Downloaded and
installed Japanese language pack, still OK.

I have no idea what was going on before, but I cannot reproduce the problem
anymore. I hope from now on like this will be. Thanx.

Comment 5

16 years ago
marking WFM as per reporter's comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
Mark bug as VERIFIED, please reopen if it is reproducible.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

16 years ago
The bug reappeared after suspending and resuming the computer. I am running a
laptop (Sony Vaio F16/BP).
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 8

16 years ago
Ryjek: could you please let us know what is your build #?
(Reporter)

Comment 9

16 years ago
Build ID: 2002051006
This is regular 1.0rc2.

Comment 10

16 years ago
Ryjek: could you please try the latest build and see if it is still reproducible 
or not? Thanks.
(Reporter)

Comment 11

16 years ago
It is reproducible with the latest build 2002052408. To reproduce:

1) Start Mozilla.
2) Suspend computer without exiting Mozilla.
3) Resume computer. Try using keyboard anywhere outside Mozilla - application
error message. The error comes from Windows Explorer.

Mozilla must be running when the computer is suspended. Otherwise, everything is
fine.

Maybe it doesn't have anything to do with the OS being Japanese ...

Comment 12

16 years ago
>Maybe it doesn't have anything to do with the OS being Japanese ...
symptom doesn't look like OS-Ja specific.

ruixu/qa: can you verify on any Win98?

Comment 13

16 years ago
I could not repro this bug with the latest build.

Ryjek: could you please try the latest build and see if it is still reproducible 
or not? and are you using Japanese 106 keyboard or English 101 keyboard to repro 
this bug? Thanks.
(Reporter)

Comment 14

16 years ago
The problem is still reproducible with build 2002070204. Start mozilla, suspend
computer, resume - and here it is.

Also, I noticed the bug without suspending the laptop. After surfing for about
30 minutes the keyboard became unusable.

Since this is a laptop, its keyboard is not full size and it is neither 101 nor
106 keys. However, since it has three extra kanji-handling keys and a function
key, I think it is closer to 106 than to 101. I just counted and there are 92
keys in it.

Comment 15

15 years ago
accepting for now and changing severity to 'major'
Severity: blocker → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 16

15 years ago
The problem was identified as a bug in the driver of the laptop's touch pad.
Updating the driver removed the errors (in case anyone has a similar problem:
http://www.ita.sel.sony.com/support/pc/pcgf150f160/softupdates)

Comment 17

13 years ago
I think both roy and me are off mozilla for more than 2 years. If these bugs are
still here now, I think the real stauts is 'won't fix'. If you want to reopen
it, please find a new owner for it first. 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → WONTFIX

Comment 18

13 years ago
Mass Reassign Please excuse the spam
Assignee: tetsuroy → nobody

Comment 19

13 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 20

13 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW

Comment 21

12 years ago
this can't possibly still be valid, can it?
(Reporter)

Comment 22

12 years ago
(In reply to comment #21)
> this can't possibly still be valid, can it?

I wouldn't bother.

Comment 23

12 years ago
(In reply to comment #16)
> The problem was identified as a bug in the driver of the laptop's touch pad.
> Updating the driver removed the errors (in case anyone has a similar problem:
> http://www.ita.sel.sony.com/support/pc/pcgf150f160/softupdates)

so ... invalid
Status: NEW → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.