New Mozilla user-agent standard

VERIFIED WONTFIX

Status

--
enhancement
VERIFIED WONTFIX
17 years ago
14 years ago

People

(Reporter: tuxracer, Assigned: Matti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4; en-US; rv:1.0rc2) Gecko/20020510

I think it would be a good idea to have a new Mozilla user-agent standard.

For example, instead of:

Mozilla/5.0 (X11; U; Linux 2.4; en-US; rv:1.0rc2) Gecko/20020510

you could have:

Mozilla/1.0 (X11; U; Linux 2.4; en-US) Gecko/20020510

Some of us could also push the IE developers to change their useragent  from
something like:

Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

to

MSIE/5.5 (Windows 98)

I see no sense in having a wrong version number for everything just because a
decade ago browsers faked their user-agent as Mozilla and a few people's
homepages that haven't been updated in 5 years might still use a bad method of
detecting the browser.

Reproducible: Always
(Assignee)

Comment 1

17 years ago
Mozilla/5.0 is correct because we want to be compatible with the Netscape UA.
Mozilla is a complete rewrite but it contains a few pieces of code from NS4.X
and Mozilla/5.0 is correct...
And we need the RV string for many things... (branch or trunk builds....)

And i don't think MS will change their UA because it will break many pages !

->wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
For what it's worth, there is a lot of discussion on this in the newsgroup
archives. Please read that before reopening, since you will need to be able to
explain why the decision that was reached is wrong.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.