Closed Bug 1455308 Opened 4 years ago Closed 4 years ago

Intermittent /websockets/unload-a-document/001.html?wss | WebSockets: navigating top-level browsing context - assert_unreached: document was not discarded Reached unreachable code

Categories

(Core :: Networking: WebSockets, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1372789

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: shindli [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=174504918&repo=mozilla-central

https://queue.taskcluster.net/v1/task/SSH5KR5gQwOk5WknXqEt0Q/runs/0/artifacts/public/logs/live_backing.log

12:05:39     INFO - 
12:05:39     INFO - TEST-UNEXPECTED-FAIL | /websockets/unload-a-document/001.html?wss | WebSockets: navigating top-level browsing context - assert_unreached: document was not discarded Reached unreachable code
12:05:39     INFO - ws.onopen</<@http://web-platform.test:8000/websockets/unload-a-document/001-1.html:21:9
12:05:39     INFO - Test.prototype.step_timeout/<@http://web-platform.test:8000/resources/testharness.js:1559:20
12:05:39     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1501:20
It fails here:

https://searchfox.org/mozilla-central/rev/59a9a86553e9bfd9277202748ff791fd9bc0713b/testing/web-platform/tests/websockets/unload-a-document/001-1.html#21

No idea what controller.navigate() does and if the timeout of 1s is simply too short.
Flags: needinfo?(james)
Controller.navigate is defined at https://searchfox.org/mozilla-central/rev/59a9a86553e9bfd9277202748ff791fd9bc0713b/testing/web-platform/tests/websockets/unload-a-document/001.html#22

You could certainly try increasing the timeout.
Flags: needinfo?(james)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1372789
You need to log in before you can comment on or make changes to this bug.