Closed Bug 1455513 Opened 3 years ago Closed 3 years ago

[a11y] Console input area should not be treated as a live region

Categories

(DevTools :: Console, defect)

defect
Not set
normal

Tracking

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61 fixed)

RESOLVED FIXED
Firefox 61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: Jamie, Assigned: nchevobbe)

References

Details

(Keywords: access, regression)

Attachments

(1 file)

STR (with the NVDA screen reader):
1. Start NVDA and Firefox.
2. Open the Web Console with control+shift+k.
3. Ensure NVDA's speak typed characters function is off by pressing NVDA+2 until it reports as off.
4. Type "z" (no quotes).
Expected: NVDA shouldn't say anything.
Actual: NVDA says "z".

The input textarea (class: jsterm-input-node) is now inside the element with the aria-live attribute (id: output-container), so it inherits aria-live. Previously, it was outside the aria-live element. This can be fixed by just setting aria-live="off" on the textarea.

I'm not exactly sure when this regressed, but it works as expected in Firefox 60.
This was probably caused by Bug 1425521 (which also mean we should have a test for that)
Has Regression Range: --- → yes
Has STR: --- → yes
Depends on: 1425521
James, I'm trying to fix this, and I set the aria-live attribute to off on the .jsterm-input-container element.
It seems to propagate to the textareas since I can inspect them with the accessibility tool and see that "container-live" is "off".
I'd like to have a test for that so we don't regress anymore, but I can't find a way to check for this "container-live" attribute in js. Would you know how I can do that ?
Unfortunately, container-live is generated internally by the accessibility engine. As far as I know, there's no way to access that from js.
Okay, thanks. I guess I'll go with a function that walk up the dom tree until it finds an "aria-live" attribute and check it's off (or that there's no parent with  aria-live).
Comment on attachment 8970116 [details]
Bug 1455513 - Do not treat jsterm as a live region; .

https://reviewboard.mozilla.org/r/238912/#review244848

Looks good, and I Tested locally and it works. Thanks!
Attachment #8970116 - Flags: review?(jteh) → review+
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4b851036974d
Do not treat jsterm as a live region; r=Jamie.
https://hg.mozilla.org/mozilla-central/rev/4b851036974d
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Blocks: 1425521
No longer depends on: 1425521
Flags: in-testsuite+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.