Clicking on link crashes browser (TB6431960G)

VERIFIED DUPLICATE of bug 145272

Status

()

Core
Layout
P3
critical
VERIFIED DUPLICATE of bug 145272
16 years ago
16 years ago

People

(Reporter: Ashley Bischoff (blog at handcoding.com), Assigned: karnaze (gone))

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020518
BuildID:    2002051808

Clicking on the "Under the Hood" link on the left crashes Mozilla.

Reproducible: Always
Steps to Reproduce:
1. Click on the "Under the Hood" link on the left

Actual Results:  Crash

Expected Results:  No crash :)

Talkback IDs: TB6431964K, TB6431962X, TB6431960G
CC: stephend@netscape.com, for Talkback retrieval please (TB6431960G)
Keywords: crash

Comment 2

16 years ago
No crash with Linux 2002051809 branch.
from win2k build 20020518.. :

nsHTMLReflowCommand::GetType(nsReflowType & 536899072) line 163 + 6 bytes
nsTableOuterFrame::IR_TargetIsCaptionFrame(nsTableOuterFrame * const 0x04e97908, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1158
nsTableOuterFrame::IR_TargetIsChild(nsTableOuterFrame * const 0x04e97908, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0, nsIFrame * 0x04e98580) line 1101 + 
31 bytes
nsTableOuterFrame::IncrementalReflow(nsTableOuterFrame * const 0x04e97908, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1078 + 42 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x04e97908, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1577 + 31 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason 
eReflowReason_Incremental, nsIFrame * 0x04e97908, const nsRect & {...}, int 0, 
nsCollapsingMargin & {...}, int 1, nsMargin & {...}, unsigned int & 0) line 570 
+ 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x04e97908, const nsRect & {...}, 
int 0, nsCollapsingMargin & {...}, int 1, nsMargin & {...}, unsigned int & 0) 
line 346 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineList_iterator 
{...}, int * 0x0012b754) line 3166 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineList_iterator {...}, 
int * 0x0012b754, int 1) line 2429 + 27 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2211 + 31 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x04e9aed4, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 946 + 15 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason 
eReflowReason_Incremental, nsIFrame * 0x04e9aed4, const nsRect & {...}, int 1, 
nsCollapsingMargin & {...}, int 0, nsMargin & {...}, unsigned int & 0) line 570 
+ 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x04e9aed4, const nsRect & {...}, 
int 1, nsCollapsingMargin & {...}, int 0, nsMargin & {...}, unsigned int & 0) 
line 346 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineList_iterator 
{...}, int * 0x0012c374) line 3166 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineList_iterator {...}, 
int * 0x0012c374, int 1) line 2429 + 27 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2211 + 31 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x04e936d8, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 946 + 15 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x04e936d8, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 784 + 31 bytes
nsTableCellFrame::Reflow(nsTableCellFrame * const 0x04e93678, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 950
nsContainerFrame::ReflowChild(nsIFrame * 0x04e93678, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 784 + 31 bytes
nsTableRowFrame::IR_TargetIsChild(nsTableRowFrame * const 0x04e934ac, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, nsTableFrame & {...}, unsigned int & 0, nsIFrame * 
0x04e93678) line 1297 + 45 bytes
nsTableRowFrame::IncrementalReflow(nsTableRowFrame * const 0x04e934ac, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, nsTableFrame & {...}, unsigned int & 0) line 1187 + 
46 bytes
nsTableRowFrame::Reflow(nsTableRowFrame * const 0x04e934ac, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1450 + 35 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x04e934ac, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 784 + 31 bytes
nsTableRowGroupFrame::IR_TargetIsChild(nsTableRowGroupFrame * const 0x04ed8060, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, nsRowGroupReflowState 
& {...}, unsigned int & 0, nsIFrame * 0x04e934ac) line 1621 + 45 bytes
nsTableRowGroupFrame::IncrementalReflow(nsTableRowGroupFrame * const 0x04ed8060, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, nsRowGroupReflowState 
& {...}, unsigned int & 0) line 1290 + 42 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x04ed8060, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1200 + 31 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x04ed8060, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 784 + 31 bytes
nsTableFrame::IR_TargetIsChild(nsTableFrame * const 0x04e931a4, nsIPresContext * 
0x04e06ad8, nsTableReflowState & {...}, unsigned int & 0, nsIFrame * 0x04ed8060) 
line 3042 + 50 bytes
nsTableFrame::IncrementalReflow(nsTableFrame * const 0x04e931a4, nsIPresContext 
* 0x04e06ad8, const nsHTMLReflowState & {...}, unsigned int & 0) line 2770 + 38 
bytes
nsTableFrame::Reflow(nsTableFrame * const 0x04e931a4, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 2024 + 27 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x04e931a4, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 3, unsigned int & 0) line 784 + 31 bytes
nsTableOuterFrame::OuterReflowChild(nsTableOuterFrame * const 0x04e92fac, 
nsIPresContext * 0x04e06ad8, nsIFrame * 0x04e931a4, const nsHTMLReflowState & 
{...}, nsHTMLReflowMetrics & {...}, int * 0x00000000, nsSize & {...}, nsMargin & 
{...}, nsMargin & {...}, nsMargin & {...}, nsReflowReason 
eReflowReason_Incremental, unsigned int & 0) line 1027 + 47 bytes
nsTableOuterFrame::IR_InnerTableReflow(nsTableOuterFrame * const 0x04e92fac, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1338 + 66 bytes
nsTableOuterFrame::IR_TargetIsInnerTableFrame(nsTableOuterFrame * const 
0x04e92fac, nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1126 + 31 bytes
nsTableOuterFrame::IR_TargetIsChild(nsTableOuterFrame * const 0x04e92fac, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0, nsIFrame * 0x04e931a4) line 1098 + 
31 bytes
nsTableOuterFrame::IncrementalReflow(nsTableOuterFrame * const 0x04e92fac, 
nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1078 + 42 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x04e92fac, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1577 + 31 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason 
eReflowReason_Incremental, nsIFrame * 0x04e92fac, const nsRect & {...}, int 0, 
nsCollapsingMargin & {...}, int 1, nsMargin & {...}, unsigned int & 0) line 570 
+ 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x04e92fac, const nsRect & {...}, 
int 0, nsCollapsingMargin & {...}, int 1, nsMargin & {...}, unsigned int & 0) 
line 346 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineList_iterator 
{...}, int * 0x0012df2c) line 3166 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineList_iterator {...}, 
int * 0x0012df2c, int 1) line 2429 + 27 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2211 + 31 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x04e92ab8, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 946 + 15 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason 
eReflowReason_Incremental, nsIFrame * 0x04e92ab8, const nsRect & {...}, int 1, 
nsCollapsingMargin & {...}, int 1, nsMargin & {...}, unsigned int & 0) line 570 
+ 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x04e92ab8, const nsRect & {...}, 
int 1, nsCollapsingMargin & {...}, int 1, nsMargin & {...}, unsigned int & 0) 
line 346 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineList_iterator 
{...}, int * 0x0012eb4c) line 3166 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineList_iterator {...}, 
int * 0x0012eb4c, int 1) line 2429 + 27 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2211 + 31 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x04e41c18, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 946 + 15 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x04e41c18, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 784 + 31 bytes
CanvasFrame::Reflow(CanvasFrame * const 0x04ed7808, nsIPresContext * 0x04e06ad8, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 564
nsBoxToBlockAdaptor::Reflow(nsBoxLayoutState & {...}, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0, int 0, int 0, int 12810, int 8235, int 1) line 883
nsBoxToBlockAdaptor::DoLayout(nsBoxToBlockAdaptor * const 0x04e41b7c, 
nsBoxLayoutState & {...}) line 626 + 46 bytes
nsBox::Layout(nsBox * const 0x04e41b7c, nsBoxLayoutState & {...}) line 1052
nsScrollBoxFrame::DoLayout(nsScrollBoxFrame * const 0x04ed7cd8, nsBoxLayoutState 
& {...}) line 395
nsBox::Layout(nsBox * const 0x04ed7cd8, nsBoxLayoutState & {...}) line 1052
nsContainerBox::LayoutChildAt(nsBoxLayoutState & {...}, nsIBox * 0x04ed7cd8, 
const nsRect & {...}) line 646 + 16 bytes
nsGfxScrollFrameInner::LayoutBox(nsBoxLayoutState & {...}, nsIBox * 0x04ed7cd8, 
const nsRect & {...}) line 1062 + 17 bytes
nsGfxScrollFrameInner::Layout(nsBoxLayoutState & {...}) line 1217
nsGfxScrollFrame::DoLayout(nsGfxScrollFrame * const 0x04ed7ae0, nsBoxLayoutState 
& {...}) line 1070 + 15 bytes
nsBox::Layout(nsBox * const 0x04ed7ae0, nsBoxLayoutState & {...}) line 1052
nsBoxFrame::Reflow(nsBoxFrame * const 0x04ed7aa8, nsIPresContext * 0x04e06ad8, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 1001
nsGfxScrollFrame::Reflow(nsGfxScrollFrame * const 0x04ed7aa8, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 777 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x04ed7aa8, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 784 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x04ed77cc, nsIPresContext * 
0x04e06ad8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 607
IncrementalReflow::Dispatch(nsIPresContext * 0x04e06ad8, nsHTMLReflowMetrics & 
{...}, const nsSize & {...}, nsIRenderingContext & {...}) line 943
PresShell::ProcessReflowCommands(int 1) line 6371
ReflowEvent::HandleEvent() line 6228
HandlePLEvent(ReflowEvent * 0x04df27c8) line 6242
PL_HandleEvent(PLEvent * 0x04df27c8) line 596 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0104f078) line 526 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x006c010a, unsigned int 49414, unsigned int 0, 
long 17100920) line 1077 + 9 bytes
USER32! 77e01b60()
USER32! 77e01cca()
USER32! 77e083f1()
nsAppShellService::Run(nsAppShellService * const 0x010e2a88) line 451
main1(int 2, char * * 0x002830b0, nsISupports * 0x00000000) line 1456 + 32 bytes
main(int 2, char * * 0x002830b0) line 1805 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e7d326()

-> Layout
Assignee: Matti → attinasi
Component: Browser-General → Layout
QA Contact: imajes-qa → petersen

Comment 4

16 years ago
Changing QA contact to Amar
QA Contact: petersen → amar

Comment 5

16 years ago
 I cant find "Under the Hood" link in the given URL. Might have changed the 
site. 
Priority: -- → P3
Amar: Nah, the site hasn't changed ;). The "Under the Hood" link is part of the
navigation on the far-left of the page.
Summary: Clicking on link crashes browser → Clicking on link crashes browser (TB6431960G)
Reassigning to karnaze
Assignee: attinasi → karnaze
(Assignee)

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 145272 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
 Verified dupe of bug 145272
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.