Closed Bug 1455550 Opened 2 years ago Closed 2 years ago

[Tab Bar Navigation] The content of the Meatball Menu is displayed outside the browser window

Categories

(DevTools :: General, defect, P2)

61 Branch
All
Unspecified
defect

Tracking

(firefox61 affected)

RESOLVED DUPLICATE of bug 1461522
Tracking Status
firefox61 --- affected

People

(Reporter: Ovidiu, Unassigned)

References

(Blocks 1 open bug)

Details

[Affected versions]: 
Nightly 61.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Windows 7 x 32, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:

1. Open Firefox 
2. Open the Inspector
3. Click the Meatball Menu(Customize Developer Tools and get help )

[Expected result]:
The extended state should be displayed inside the browser window.

[Actual result]:
The extended state (a part of the MeatBall Menu) is displayed outside of the browser window.

Note: Please take a look at the hamburger menu (the menu button from Firefox) and see that the content of the expended state is displayed inside the browser window.
It would be great to see a screenshot of this bug.
Sure, I did a screen recording. 
You can see it here: https://streamable.com/uh2o3
Please let me know if you need more details.
Brian: I think I remember this being discussed perhaps on another bug, could this be a duplicate?
Victoria: what's your take on this? This new menu is just like any operating system context menu, and will appear anywhere there is space for it. If the browser window is close to the edge of the screen, then the menu will appear inside the window.
The fact that it's consistent with other menus is nice. But I understand the point of it being inconsistent with the Firefox hamburger menu. I just don't know if it's important for them to look and feel the same.
Flags: needinfo?(victoria)
Flags: needinfo?(bbirtles)
Yes, this is a dupe of bug 1455550. I don't really know what the correct behavior is. As a Windows user I expect it to expand to the right when possible (i.e. go outside the window). I guess when we switch to a XUL panel (or equivalent) it will be easier to argue for consistency with the hamburger menu so perhaps we should just fix it then.
Flags: needinfo?(bbirtles)
(In reply to Brian Birtles (:birtles) from comment #4)
> Yes, this is a dupe of bug 1455550.

Oops, that's this bug :/
Depends on: 1461522
See Also: → 1460207
I generally expect menus to expand to the right beyond the window, as that is the Mac behavior as well. Also, it seems slightly better for usability because the eye and cursor moves a shorter distance to the beginning of the first menu item.

I think I agree with Brian's point that when we switch to the custom panel it would make sense to match the main hamburger behavior. (I'm going to ask the UX team about this to learn more about their reasoning.)
Flags: needinfo?(victoria)
Severity: normal → enhancement
Priority: -- → P2
Product: Firefox → DevTools
This is fixed by bug 1461522.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1461522
You need to log in before you can comment on or make changes to this bug.