"Save As..." cancel leaves URL inaccessible on certain URLs

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
2 years ago

People

(Reporter: Tyson, Assigned: law)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051005

When viewing a URL, if you select File > Save As ... to save a page and then
click on Cancel, then if you try to reload the page or to visit the page again
by reentering the URL, you get error messages (such as the page cannot be found).

This seems to happen on all EBay pages I've tried it on, such as
  http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=870896171
When you try to reload that page after cancelling the Save As..., you get a message 
 The file /ws/eBayISAPI.dll?ViewItem&item=870896171 cannot be found.  Please
check the location and try again.

This does not happen on other pages such as my home page.

The page is accessible if I quite Mozilla and start again.  But until I quit
Mozilla, it is not accessible (incl. in newly created browser windows)

Reproducible: Always
Steps to Reproduce:
1.  Visit an Ebay item page (go to www.ebay.com, enter a search for some term,
click on some item that shows up)
2.  Under the File menu, choose "Save Page as..."
3.  In the pop-up window that lets you chose where to save it, click on Cancel.
 (In my case, the format is already set as "Web Page, Complete")
4.  Click on Reload in the browser menu.

Actual Results:  I get a pop-up error message:
The file /ws/eBayISAPI.dll?ViewItem&item=870896171 cannot be found.  Please
check the location and try again.

Expected Results:  I expect the window to be redisplayed.

Probably this maybe should be referenced by bug 115634  which appears to be the
index to the bugs with the Save As... items.

Comment 1

17 years ago
WorksForMe using Mac/2002072203. I think this is a dup of a fixed bug. See also bug 142795.

Mabry, if you would, please retest using a recent build and let us know the results.
(Reporter)

Comment 2

16 years ago
I just got Mozilla 1.1 and this bug no longer appears.   Thanks!
(Sorry I didn't check on the status of this bug earlier.)

Since I submitted it, I hope it is ok for me to mark it as Fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
vrfy'ing per reporter.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.