Closed Bug 1455827 Opened 3 years ago Closed 3 years ago

proxy policy is not working as expected

Categories

(Firefox :: Enterprise Policies, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: soeren.hentzschel, Unassigned)

References

Details

Attachments

(2 files)

While testing the enterprise policies I noticed that the proxy policy is not working as expected. I used the current version of Firefox Nightly for the test. I didn't test with a real proxy but looked if the changes has been reflected in about:preferences.

example configuration:

{
  "policies": {
    "Proxy": {
      "Mode": "manual",
      "UseHTTPProxyForAllProtocols": false,
      "SOCKSVersion": 5,
      "AutoLogin": false,
      "UseProxyForDNS": true,
      "HTTPProxy": "1.2.3.5:8083",
      "SSLProxy": "2.3.4.5",
      "FTPProxy": "3.4.5.6",
      "SOCKSProxy": "4.5.6.7",
      "Passthrough": "5.6.7.8",
      "AutoConfigURL": ""
    }
  }
}

The following properties worked:

SOCKSVersion, HTTPProxy, Passthrough, AutoConfigURL

I don't know if the following properties worked because I don't know where these settings are reflected in the UI:

AutoLogin, UseProxyForDNS

The following properties didn't work:

Mode - Firefox always show "No Proxy"
UseHTTPProxyForAllProtocols - either with true or false, the checkbox is always set 

Because UseHTTPProxyForAllProtocols is not working I don't know if the following properties are working:

SSLProxy, FTPProxy, SOCKSProxy
AutoLogin corresponds to Do not prompt for authentication if password is saved.
UseProxyFor DNS corresponds to Proxy DNS when using SOCKS v5

They are both at the bottom of the dialog (you might have to scroll to the bottom of the dialog).

As far as the UseHTTPProxyForAll protocols, I'll check on that.
Attached image proxy.png
I used your exact configuration and changed 

      "UseHTTPProxyForAllProtocols": false,

to 

      "UseHTTPProxyForAllProtocols": true,

And got the correct behavior.

See attached image.
Attached image screenshot
> They are both at the bottom of the dialog (you might have to scroll to the bottom of the dialog).

Oh, I don't know how I couldn't see that. :)

> I used your exact configuration and changed […]

I attached a screenshot for the config from commment #0 on my system.

As you can see "Mode": "manual" is not working and "SSL Proxy", "FTP Proxy" and "SOCKS Host" don't have the values from my policy.
The policy sets the default values. They do not override values you already have.

Try locking the policy and see what happens.
Please see my last comment
Flags: needinfo?(cadeyrn)
Status: NEW → UNCONFIRMED
Ever confirmed: false
Sorry for the delay.

I tested again with today's Nightly version of Firefox. "Mode": "manual" works now. But SSLProxy, FTPProxy and SOCKSProxy doesn't work.

If I set UseHTTPProxyForAllProtocols to true, SSLProxy, FTPProxy and SOCKSProxy have the same value as HTTPProxy (as expected). But If I set UseHTTPProxyForAllProtocols to false, SSLProxy, FTPProxy and SOCKSProxy all have 185.7.19.173:8080 as value.

Locking the policy doesn't change that.
Flags: needinfo?(cadeyrn)
Hi there! I'll need more help understanding what's going on here, since I got a bit lost on the comments.

Are you working on a profile that already had previous settings around proxy? what is the behavior you expected to happen (vs. what is happening). Can you provide more details?

One thing to note is that if you don't use Locked = true, the settings provided will only take place if there's no user-set value stored.

Also, take a look at the Browser Console to see if there are any errors reported. You can also set browser.policies.loglevel to "debug" to get more detailed information.


Since I know you are familiar with some of our code, please take a look at 
https://searchfox.org/mozilla-central/rev/5a744713370ec47969595e369fd5125f123e6d24/browser/components/enterprisepolicies/helpers/ProxyPolicies.jsm#87 to see if the behavior you're seeing is actually unexpected
Flags: needinfo?(cadeyrn)
Priority: -- → P2
Hi!

> Are you working on a profile that already had previous settings around proxy? what is the behavior you expected to happen (vs. what is happening). Can you provide more details?

It seems there were already some values in my proxy settings and I expected the policy to override these values, even without the "Locked" option. After emptying all fields the policy seems to work. 

I guess it's the intended behaviour so I will resolve this bug as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(cadeyrn)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.