[Tree]Profile & tune treewidget code

VERIFIED DUPLICATE of bug 9489

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 9489
19 years ago
10 years ago

People

(Reporter: Chris Waterson, Assigned: Chris Waterson)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Perf])

(Assignee)

Description

19 years ago
e.g., nsCSSFrameConstructor::CreateAnonymousTreecellFrames (which is called a
_lot_ for big trees) uses nsString for automatic variables, NS_NewAtom()
instead of nsXULAtoms, etc.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12

Updated

19 years ago
Summary: [perf] profile & tune treewidget code → Profile & tune treewidget code
Whiteboard: [Perf]

Updated

18 years ago
Summary: Profile & tune treewidget code → [Tree]Profile & tune treewidget code

Comment 1

18 years ago
Marking [Tree]
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

18 years ago
*** This bug has been marked as a duplicate of 9489 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
Marking VERIFIED DUPLICATE per waterson's comments.

Comment 4

18 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: ckritzer → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.