Closed Bug 1456025 Opened 5 years ago Closed 4 years ago

Content process killed on cairo-gtk3-wayland build when e10s is enabled

Categories

(Core :: Graphics, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1462640

People

(Reporter: cosmo0920, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20180326230345

Steps to reproduce:

Checkout m-c source tree:

revision is:
---
commit b9a82af44a65f2d8d3c3d9f0b75a3ce7bbe468c3
Author: Cosmin Sabou <csabou@mozilla.com>
Date:   Fri Apr 20 06:47:41 2018 +0300

    Backed out 2 changesets (bug 1387399) for OSX reftests permafailures on attachment-local-positi
oning-2.html. a=backout
    
    Backed out changeset b78a225fa8c9 (bug 1387399)
    Backed out changeset 4beeacb75bf5 (bug 1387399)
---

Build with the following configuration:

---
. $topsrcdir/browser/config/mozconfig

ac_add_options --enable-default-toolkit=cairo-gtk3-wayland

mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-wayland
mk_add_options AUTOCLOBBER=1

ac_add_options --disable-crashreporter
ac_add_options --without-system-nspr
ac_add_options --without-system-nss

ac_add_options --enable-debug
ac_add_options --disable-optimize

ac_add_options --enable-release
ac_add_options --enable-tests
---

Then e10s is disabled, enable layers acceleration, and enable webgl:

---
layers.acceleration.force-enabled	true
webgl.force-enabled	true
```

Access http://helloracer.com/webgl/.


Actual results:

Content Process killed.

Logs:
---
JavaScript warning: http://helloracer.com/webgl/js/Three.js, line 242: Error: WebGL warning: Disallowing antialiased backbuffers due to blacklisting.
Attempting load of libEGL.so
Sandbox: seccomp sandbox violation: pid 5524, tid 5524, syscall 27, args 140354013335552 4096 140725271839415 1464 0 140354041287392.  Killing process.
Sandbox: crash reporter is disabled (or failed); trying stack trace:
Sandbox: frame #01: ???[/lib/x86_64-linux-gnu/libpthread.so.0 +0x110c0]
Sandbox: frame #02: mincore[/lib/x86_64-linux-gnu/libc.so.6 +0xe4597]
Sandbox: frame #03: ???[/usr/lib/x86_64-linux-gnu/libEGL.so +0x118df]
Sandbox: frame #04: eglGetDisplay[/usr/lib/x86_64-linux-gnu/libEGL.so +0x83b5]
Sandbox: frame #05: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x21a5f63]
Sandbox: frame #06: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x21b8a10]
Sandbox: frame #07: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x21ba4d0]
Sandbox: frame #08: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x21b98a1]
Sandbox: frame #09: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x21b84de]
Sandbox: frame #10: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x36e9e26]
Sandbox: frame #11: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x36ea06b]
Sandbox: frame #12: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x36ea6c6]
Sandbox: frame #13: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x36eb4bf]
Sandbox: frame #14: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x369ae38]
Sandbox: frame #15: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x369abd6]
Sandbox: frame #16: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x3ae093c]
Sandbox: frame #17: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x34557a2]
Sandbox: frame #18: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x360ae63]
Sandbox: frame #19: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6b6e55d]
Sandbox: frame #20: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6b7931e]
Sandbox: frame #21: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6b796b0]
Sandbox: frame #22: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6b796da]
Sandbox: frame #23: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6b874d3]
Sandbox: frame #24: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6b78eca]
Sandbox: frame #25: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6b7a3d7]
Sandbox: frame #26: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6b7a697]
Sandbox: frame #27: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x710b3d2]
Sandbox: frame #28: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x710b5fa]
Sandbox: frame #29: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x710b7b1]
Sandbox: frame #30: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x2944caf]
Sandbox: frame #31: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x472dc1b]
Sandbox: frame #32: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x472bf1c]
Sandbox: frame #33: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x4729e0d]
Sandbox: frame #34: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x4729321]
Sandbox: frame #35: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x471f82a]
Sandbox: frame #36: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x1ffe3ef]
Sandbox: frame #37: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x2022d10]
Sandbox: frame #38: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x20223ab]
Sandbox: frame #39: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x2020c0e]
Sandbox: frame #40: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0xfe4e6c]
Sandbox: frame #41: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0xff54e6]
Sandbox: frame #42: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x100efed]
Sandbox: frame #43: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x1745d63]
Sandbox: frame #44: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x17466a8]
Sandbox: frame #45: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x16dd34b]
Sandbox: frame #46: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x16dd2de]
Sandbox: frame #47: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x16dd2b7]
Sandbox: frame #48: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x4884510]
Sandbox: frame #49: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6a0ba33]
Sandbox: frame #50: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x1746555]
Sandbox: frame #51: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x16dd34b]
Sandbox: frame #52: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x16dd2de]
Sandbox: frame #53: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x16dd2b7]
Sandbox: frame #54: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6a0b8c1]
Sandbox: frame #55: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/libxul.so +0x6a0c508]
Sandbox: frame #56: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/firefox +0x60d1]
Sandbox: frame #57: ???[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/firefox +0x662f]
Sandbox: frame #58: __libc_start_main[/lib/x86_64-linux-gnu/libc.so.6 +0x202e1]
Sandbox: frame #59: _start[/home/hhatake/GitHub/gecko-dev/objdir-wayland/dist/bin/firefox +0x5d0a]
Sandbox: frame #60: ??? (???:???)
Sandbox: end of stack.
Sandbox: JS frame 0: THREE.WebGLRenderer/< http://helloracer.com/webgl/js/Three.js line 242
Sandbox: JS frame 1: THREE.WebGLRenderer http://helloracer.com/webgl/js/Three.js line 242
Sandbox: JS frame 2: init http://helloracer.com/webgl/js/HelloRacer.js line 4
Sandbox: JS frame 3: (anonymous) http://helloracer.com/webgl/js/HelloRacer.js line 3
--DOMWINDOW == 4 (0x7f1e195ed400) [pid = 5465] [serial = 11] [outer = (nil)] [url = about:blank]

###!!! [Parent][RunMessage] Error: Channel error: cannot send/recv


###!!! [Parent][RunMessage] Error: Channel error: cannot send/recv


###!!! [Parent][RunMessage] Error: Channel error: cannot send/recv


###!!! [Parent][RunMessage] Error: Channel error: cannot send/recv


###!!! [Parent][RunMessage] Error: Channel error: cannot send/recv


###!!! [Parent][RunMessage] Error: Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x490017,name=PHttpChannel::Msg_DeleteSelf) Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x490017,name=PHttpChannel::Msg_DeleteSelf) Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x16007F,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

--


Expected results:

Rendered contents with WebGL can be seen.
Component: Untriaged → Graphics
Product: Firefox → Core
Blocks: wayland
Priority: -- → P5
Whiteboard: [gfx-noted]
Depends on: 1462640
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1462640
You need to log in before you can comment on or make changes to this bug.