Closed Bug 1456049 Opened 2 years ago Closed 2 years ago

crashed in HTMLTableAccessible

Categories

(Core :: Disability Access APIs, defect, critical)

59 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1451673

People

(Reporter: davidwangtf, Unassigned)

References

()

Details

(Keywords: crash)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Steps to reproduce:

Open a html with a table of 3 columns and 3 rows.


Actual results:

The firefox just crashed. The crash report is here https://crash-stats.mozilla.com/report/index/59a1af2d-236b-4b47-8a57-e4ead1180423

After analysed the code of HTMLTableAccessible.cpp, I think "rowFrame" need be checked not NULL at the line 1072 of  HTMLTableAccessible.cpp.

The code is here:
https://hg.mozilla.org/releases/mozilla-release/annotate/239e434d6d2b/accessible/html/HTMLTableAccessible.cpp#l1072
Thank you for the detailed report. This looks like bug 1451673. Please check if the problem occurs with the latest Nightly in a brand new profile.
https://nightly.mozilla.org
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Severity: normal → critical
Component: Untriaged → Disability Access APIs
Flags: needinfo?(davidwangtf)
Keywords: crash
Product: Firefox → Core
it looks indeed a dupe of bug 1451673
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1451673
Flags: needinfo?(davidwangtf)
You need to log in before you can comment on or make changes to this bug.