Closed Bug 1456082 Opened 6 years ago Closed 6 years ago

When opening a new tab, it shows a completely white screen.

Categories

(Firefox :: New Tab Page, defect, P1)

x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 61
Iteration:
61.4 - May 7
Tracking Status
firefox61 --- verified
firefox62 --- verified

People

(Reporter: duttaditya18, Assigned: andreio)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180419200216

Steps to reproduce:

Open a new tab. (not the one that appears at the start.)


Actual results:

It shows a completely white screen with the title : New Tab

See this : https://i.imgur.com/J4bTUYL.png


Expected results:

It should have showed the normal new tab, which it shows when Firefox starts for the first time. (or while opening a new tab)

Like this : https://i.imgur.com/0kj1utf.png
OS: Unspecified → Windows 10
Can confirm. This is happening since at least 21st April build. Although, I doubt that Firefox build version has anything to do with this since the code is sitting in an addon. Thus, this might be platform/os independent as well - but I can only confirm for Windows 10 x64.

This is the error observed in the browser console - 

Error: storeNames and telemetry are required, called only with storeNames,telemetry view-source:resource://activity-stream/lib/ActivityStreamStorage.jsm:9:13

This is the activity stream version from about:support page - 2018.04.20.1268-306bd7e2

One question - There were automated tests for new tab page to capture these simple failures. Is activity stream going to continue as an addon? Are there plans to add automated tests for an addon code?
Status: UNCONFIRMED → NEW
Component: Untriaged → Activity Streams: Newtab
Ever confirmed: true
Hardware: Unspecified → x86_64
Version: 60 Branch → Trunk
Assignee: nobody → andrei.br92
Activity Stream does have automated tests (see https://dxr.mozilla.org/mozilla-central/source/browser/extensions/activity-stream/test), but it seems that they did not catch this particular issue. We will look into adding one.
Iteration: --- → 61.4 - May 7
Thanks for reporting this. Just to confirm that I'm looking into the correct failure can you tell me the value of your `browser.newtabpage.activity-stream.feeds.telemetry` pref? Thanks.
Flags: needinfo?(scrapmachines)
(In reply to Andrei Oprea [:andreio] from comment #3)
> Thanks for reporting this. Just to confirm that I'm looking into the correct
> failure can you tell me the value of your
> `browser.newtabpage.activity-stream.feeds.telemetry` pref? Thanks.

It's false
Flags: needinfo?(scrapmachines)
(In reply to Kate Hudson :k88hudson from comment #2)
> Activity Stream does have automated tests (see
> https://dxr.mozilla.org/mozilla-central/source/browser/extensions/activity-
> stream/test), but it seems that they did not catch this particular issue. We
> will look into adding one.

Oh. Thanks for the reply. Wasn't aware that extensions can have automated tests.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
When will I see this in fixed in Firefox Developer Edition?
Status: RESOLVED → VERIFIED
This change needs to make it to Nightly 61 first. Looks like dev edition builds once a week during the 61 soft code freeze, before 61 is fully in Beta where it switches to builds twice a week.
Status: VERIFIED → RESOLVED
Closed: 6 years ago6 years ago
Blocks: 1457543
Exactly how long before this lands in nightly? It has been two days. Is this waiting for AMO review?
Priority: -- → P1
Flags: qe-verify+
I reproduced this issue using Firefox 61.0a1 (2018-04-23), on Windows 10 x64.
I can confirm this issue is fixed, I verified using Firefox 62.0a1 (2018-05-09)and Firefox 61.0b3 on Windows 10 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: