Closed Bug 14561 Opened 21 years ago Closed 21 years ago

We don't get the compose window back if smtp returns an error

Categories

(MailNews Core :: Composition, defect, P3)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mscott, Assigned: bugzilla)

Details

Attachments

(1 file)

If for some reason sending a message failed and the smtp code returned an error,
we used to bring the original compose window back into existence so the user
wouldn't loose the message.

That's no longer true today. If I return an error code through a OnStopRequest
call into the smtp protocol's url listener, the send delivery listener doesn't
bring the compose window back.

I'm hoping Jean-Francois might know how this works. I tried to look at it but
didn't have much sucess.

What may be a side effect of this...I noticed you can now send a message without
a subject. You used to get prompted about the subject in 5.0. Or so I thought.

Jean-Francois, I'd be happy to try to track down why the compose window doesn't
go back if you know where to start looking. Some of the code may have been
rhp's....
Status: NEW → ASSIGNED
Target Milestone: M10
Whiteboard: I have the fix, waiting for review and approval
The problem is due by the fact that we use some positive string ID as error code. Just cleanup the mess and

everything will work fine.



mscott, could you review the fix. Thanks
Whiteboard: I have the fix, waiting for review and approval → I have the fix, waiting for approval
Fix has been reviewd by mscott
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fixed and checked in (M10 Branch only)
Are you going to check into the trunk M11 also?
Yes, I will...
Whiteboard: I have the fix, waiting for approval
Fix checked in the trunk (M11).
QA Contact: lchiang → esther
Status: RESOLVED → VERIFIED
Using build 1999111017 on win and linux and 1999111111 on mac when I try to send
a message without a recipient, I get the correct alert, the compose window is
still up front and when I OK the alert the compose window is still there.  I
believe this bug is for bringing back the compose window when a send fails
because of an alert, if this is fixed.  If this bug is asking for an alert when
there is no Subject, that is not fixed.  I will verify per my belief, if there
should be an alert for no subject, I will log a separate bug.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.