Closed Bug 1456103 Opened Last year Closed Last year

Create tests for devtools.main.deactivate telemetry event

Categories

(DevTools :: General, enhancement, P2)

57 Branch
enhancement

Tracking

(firefox61 fixed)

RESOLVED FIXED
Firefox 61
Tracking Status
firefox61 --- fixed

People

(Reporter: miker, Assigned: miker)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Moving to M1 for splitting off M2 work.
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Comment on attachment 8971163 [details]
Bug 1456103 - Create tests for devtools.main.deactivate telemetry event

https://reviewboard.mozilla.org/r/239962/#review245682

this looks good, I am just wondering about the duplicate information?

::: devtools/client/framework/test/browser_toolbox_telemetry_activate_splitconsole.js:44
(Diff revision 1)
>      }
> +  }, {
> +    timestamp: null,
> +    category: "devtools.main",
> +    method: "deactivate",
> +    object: "split_console",

this looks like the same information as in 22-29?

::: devtools/client/responsive.html/test/browser/browser_telemetry_activate_rdm.js:43
(Diff revision 1)
>      }
> +  }, {
> +    timestamp: null,
> +    category: "devtools.main",
> +    method: "deactivate",
> +    object: "responsive_design",

same in this segment?
Attachment #8971163 - Flags: review?(ystartsev)
Comment on attachment 8971163 [details]
Bug 1456103 - Create tests for devtools.main.deactivate telemetry event

https://reviewboard.mozilla.org/r/239962/#review245716

::: devtools/client/framework/test/browser_toolbox_telemetry_activate_splitconsole.js:44
(Diff revision 1)
>      }
> +  }, {
> +    timestamp: null,
> +    category: "devtools.main",
> +    method: "deactivate",
> +    object: "split_console",

Yup, the same tool was closed so that is correct.

::: devtools/client/responsive.html/test/browser/browser_telemetry_activate_rdm.js:43
(Diff revision 1)
>      }
> +  }, {
> +    timestamp: null,
> +    category: "devtools.main",
> +    method: "deactivate",
> +    object: "responsive_design",

Yes, that is correct.
Comment on attachment 8971163 [details]
Bug 1456103 - Create tests for devtools.main.deactivate telemetry event

https://reviewboard.mozilla.org/r/239962/#review245718
Attachment #8971163 - Flags: review+
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/029547eb5a87
Create tests for devtools.main.deactivate telemetry event r=yulia
https://hg.mozilla.org/mozilla-central/rev/029547eb5a87
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.