Asynchronously notify users when a landing fails

RESOLVED FIXED

Status

enhancement
P2
normal
RESOLVED FIXED
Last year
4 months ago

People

(Reporter: smacleod, Assigned: mars)

Tracking

({conduit-triaged})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

It is possible transplant can fail to land something which Lando has queued. When this happens visiting the Lando page will display that the landing has failed, but there is no asynchronous notification (email, bug, etc) to the lander. MozReview + Autoland initially had this problem and it was a big pain.

We should add some notification mechanism to Lando so that landers know a landing has failed.
Keywords: conduit-triaged
Whiteboard: [lando-backlog]
See Also: → 1460364
Duplicate of this bug: 1232736
Keywords: conduit-story
Whiteboard: [lando-backlog]
Just a note that in the duplicate bug it was suggested to flag for needinfo on bugzilla.
Duplicate of this bug: 1489088
Assignee: nobody → mars
Status: NEW → ASSIGNED
Make the webhead-only env config variables optional so Ops doesn't need
to set unneeded vars for non-webhead processes in production.  Make the
configure_app() function handle env vars consistently.

Depends on D12691
Integrate Celery with lando-api.  Add a dummy task to Celery that logs
landing failures so we can see how the framework functions once deployed
.

Depends on D12692
Attachment #9027029 - Attachment description: Bug 1456197 - Clean up app configuration r?smacleod → Bug 1456197 - Clean up app configuration r?smacleod Make the webhead-only env config variables optional so Ops doesn't need to set unneeded vars for non-webhead processes in production. Make the configure_app() function handle env vars consistently.
Attachment #9027030 - Attachment description: Bug 1456197 - Integrate Celery r?smacleod → Bug 1456197 - Integrate Celery r?smacleod Integrate Celery with lando-api. Add a dummy task to Celery that logs landing failures so we can see how the framework functions once deployed .
Attachment #9027030 - Attachment description: Bug 1456197 - Integrate Celery r?smacleod Integrate Celery with lando-api. Add a dummy task to Celery that logs landing failures so we can see how the framework functions once deployed . → Bug 1456197 - Integrate Celery r?smacleod
Attachment #9027029 - Attachment description: Bug 1456197 - Clean up app configuration r?smacleod Make the webhead-only env config variables optional so Ops doesn't need to set unneeded vars for non-webhead processes in production. Make the configure_app() function handle env vars consistently. → Bug 1456197 - Clean up app configuration r?smacleod
Duplicate of this bug: 1511246
Depends on: 1512714
Use the Flask-mail library to send an email notification to the user
when their branch fails to land.
Attachment #9030493 - Attachment description: Send email when a transplant job fails → transplants: send email when a transplant job fails (bug 1456197)
Attachment #9027285 - Attachment description: Bug 1456197 - Monitor Celery tasks with Datadog r?smacleod → transplants: monitor Celery tasks with Datadog (bug 1456197)
Attachment #9027030 - Attachment description: Bug 1456197 - Integrate Celery r?smacleod → transplants: integrate Celery (bug 1456197)
Attachment #9027029 - Attachment description: Bug 1456197 - Clean up app configuration r?smacleod → config: clean up app configuration (bug 1456197)
Attachment #9027028 - Attachment description: Bug 1456197 - Make the test suite pass when run outside of docker r?smacleod → tests: make the test suite pass when run outside of docker (bug 1456197)
Depends on: 1525637

Ops says this feature will be delayed until the end of Q1 because this service's email infrastructure is migrating to GCP. Ops will be in touch when the new email system is in place and ready for testing.

Keywords: conduit-story
Priority: -- → P2

This has landed and is working in the dev environment now. Production deployment should happen this weekend.

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.