Closed Bug 1456219 Opened 2 years ago Closed 2 years ago

Add default Light- and Dark themes to TB

Categories

(Thunderbird :: Theme, enhancement)

enhancement
Not set

Tracking

(thunderbird60 fixed, thunderbird61 fixed)

RESOLVED FIXED
Thunderbird 61.0
Tracking Status
thunderbird60 --- fixed
thunderbird61 --- fixed

People

(Reporter: Paenglab, Assigned: Paenglab)

References

()

Details

Attachments

(3 files, 2 obsolete files)

FX has by default a dark and a light theme. We can follow and extend them later to theme more areas.
Attached patch Light-Dark-themes.patch (obsolete) — Splinter Review
Needs to be applied over bug 1455942.

This patch adds a dark and a light LW-theme like FX has.

They work on all platforms and I tested Win 7 Classic/Basic/Aero too.

This themes are a bit more powerful than normal LW/WX-themes because there is a compacttheme.css added that can do more.

I'm planning to extend them for example to the QFB bar, the message header and the header toolbar in composer.

I'm using now the FX icons in Add-on manager. Maybe we can add other later. But bug 1372694 will add a icon for the default theme through toolkit which makes it probably not possible to change it for us.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8970274 - Flags: review?(jorgk)
Comment on attachment 8970274 [details] [diff] [review]
Light-Dark-themes.patch

This works for me, however, it doesn't follow FF 59. There the light and default themes show the menu in the same colour as the tab bar. With the patch, menu and title bar are almost white and the tab bar is grey in the light theme. Is that intentional?
Attachment #8970274 - Flags: review?(jorgk) → review+
Fixed the issue with the menubar.
Attachment #8970274 - Attachment is obsolete: true
Attachment #8970328 - Flags: review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5bbef8b40975
Add default Light and Dark themes to TB. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 61.0
Is this strictly patch applicable to version 61+?  
The reason I ask is I've seen user requests for dark theme - which we don't have in 60.
Flags: needinfo?(richard.marti)
It should work on TB 60 too. It can be that some tweaks are needed. But this would need first to apply to TB 60 and then to be checked.
Flags: needinfo?(richard.marti)
Ah, the problem is, we have strings added. So, no uplift possible.
(In reply to Richard Marti (:Paenglab) from comment #7)
> Ah, the problem is, we have strings added. So, no uplift possible.

That's unfortunate. I know it would be generally frowned up, but would it be bad to uplift and just not have the strings translated - it's not in the main UI?
Attached patch DarkLightTheme-beta.patch (obsolete) — Splinter Review
This patch applies on beta with the strings removed. What do you think, can we somehow start a try build on beta to check how it works and what changes are needed to work properly? I have no local build system for beta.
Attachment #8970883 - Flags: feedback?(jorgk)
The strings are hard coded now.
You can just push to try from comm-beta, that works.
Do I need to define the changesets? If yes, which?
Assuming you have comm-beta checked out and are at the tip + your patch, you just do a try push with the usual syntax. Nothing else required.
I had to change two variable names which changed in 61. But now I tried it and it should work on beta.

Jörg persuaded me to let the string changes in the patch. The locales which want to translate can do it, the others would be like we hard coded the strings.
Attachment #8970883 - Attachment is obsolete: true
Attachment #8970883 - Flags: feedback?(jorgk)
Attachment #8970971 - Flags: approval-comm-beta?
Comment on attachment 8970971 [details] [diff] [review]
DarkLightTheme-beta.patch

OK, let's do it although we're going to get into trouble with L10n.
Attachment #8970971 - Flags: approval-comm-beta? → approval-comm-beta+
In try run https://taskcluster-artifacts.net/UT2oazXfRy2A2Z1btkhZHA/0/public/logs/live_backing.log there is now an error:
JavaScript error: chrome://messenger/content/addressbook/addressbook.js, line 15: ReferenceError: XPCOMUtils is not defined

Missing ChromeUtils.import("resource://gre/modules/XPCOMUtils.jsm"); in addressbook.js ?
Is it better with this?
Attachment #8971432 - Flags: review?(acelists)
Hmm, do I need this for the beta? What happens without it apart from the JS error?
Comment on attachment 8971432 [details] [diff] [review]
1456219-followup.patch

Review of attachment 8971432 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, this fixes the error (tried locally on the test-send-button.js).

I don't know what problems the missing import causes, if any. LW theme seems the apply to the AB window even with the error (albeit it is different tone than the main window).
Attachment #8971432 - Flags: review?(acelists) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/c86896b10e65
Follow-up: Import XPCOMUtils.jsm in addressbook.js. r=aceman DONTBUILD
For MacOS, is there a way to make the background of the tab bar dark in the default theme (so it matches the Firefox experience)?
(In reply to realDonaldTrump from comment #23)
> For MacOS, is there a way to make the background of the tab bar dark in the
> default theme (so it matches the Firefox experience)?

This added in userChrome.css should work:

#tabs-toolbar {
  -moz-appearance: -moz-mac-vibrant-titlebar-dark !important;
  -moz-font-smoothing-background-color: -moz-mac-vibrant-titlebar-dark !important;
  background-color: #232323 !important;
  color: hsl(240, 9%, 98%) !important;
  text-shadow: none !important;
}
(In reply to Richard Marti (:Paenglab) from comment #24)
> (In reply to realDonaldTrump from comment #23)
> > For MacOS, is there a way to make the background of the tab bar dark in the
> > default theme (so it matches the Firefox experience)?
> 
> This added in userChrome.css should work:
> 
> #tabs-toolbar {
>   -moz-appearance: -moz-mac-vibrant-titlebar-dark !important;
>   -moz-font-smoothing-background-color: -moz-mac-vibrant-titlebar-dark
> !important;
>   background-color: #232323 !important;
>   color: hsl(240, 9%, 98%) !important;
>   text-shadow: none !important;
> }

thank you for making thunderbird great again!  tremendous!!!
Depends on: 1461641
You need to log in before you can comment on or make changes to this bug.