OS X blob becomes a 'Classic Application' if its extension (.smi) is changed

VERIFIED WONTFIX

Status

SeaMonkey
Build Config
--
blocker
VERIFIED WONTFIX
16 years ago
13 years ago

People

(Reporter: garylowens, Assigned: Dawn Endico)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051005

the RC2 build accessible from
ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla1.0rc2/mozilla-macosX-100rc2.smi.bin
(ie the "MacOS X Disk Image" link on the releases page),
will download OK, but when unpacked, it is labled as a "Classic App",
so clicking on it starts Classic (os 9.X), but the app really is
a new app, so it halts with an error.

The disk image from the ftp site works OK.


Reproducible: Always
Steps to Reproduce:
1.go to mozilla.org/releases (on an OS X Mac)
2. click the MacOS X "Disk Image" link
3. select "open with Stuffit Expander"
4. after the download is complete, click on the
    mozilla-macosX-1.0.0.smi(.N) icon on the desktop
5. "accept" the license terms


Actual Results:  error dialog with:
 "unable to execute <file>, an expected error occured (-56)"

Expected Results:  a progress bar, unpacking, verifying, and then
a disk icon for the virtual disk on the desktop.



If I didn't know about the ftp site, or feel up to trying it,
I wouldn't be able to get the RC2 MacOS X build of Mozilla.

Comment 1

16 years ago
wfm with the url the reporter provided..

Mozilla runs fine and is a real mac os X app..


md5sum:
8809b0dafd4de7844c3e207f5d4196b2  mozilla-macosX-100rc2.smi.bin

Reporter: Does the build downloaded by you have the same md5sum?
md5sum is a 'checksum', .. i don't know mac os X very well but i think it should
be included in mac os X:
- Start the teriman
- Type: 'md5sum /Users/bllabla/mozillafile.smi.bin' and press enter
(Reporter)

Comment 2

16 years ago
the "good" smi.bin (via ftp) is:
8809b0dafd4de7844c3e207f5d4196b2 *mozilla-macosX-100rc2.smi.bin

the bad smi.bin files (via the web page) are:
8b57fa78c43fb34a582175667e795bc0 *mozilla-macosX-1.0.0.smi.1

I've been trying to figure this out, but as of 9:14 am PST,
the file on the ftp site is unavailable (which is odd, because the path
is ultimately the same but there could be multiple servers), and the file
on the web page is still a classic app, with or without stuffit.

FYI md5sum is NOT part of the MacOS X distribution, I found a usable GUI
tool at http://www.hornig.net/shorten.html
Would be nice to have a cli.
(Reporter)

Comment 3

16 years ago
More details, dunno if this is a bug or one for the FAQs.

If one already has a "mozilla-macosX-1.0.0.smi" on the desktop
(say, from trying RC1), and then one gets *another* .smi.bin file, then
when one tries to run the ""mozilla-macosX-1.0.0.smi.1" (or .N" file),
it comes up in a classic style dialog for the license agreement and ultimately
fails.  (The clean .smi.bin file will run with the OS X dialog and work).
Thus, one must remove any mozilla-macosX-v.v.v.smi files one has, *before* doing
the download, or one can remove the .smi file after the download and run the
.bin file (ie if there is no "mozilla-macosX-1.0.0.smi", even a
"mozilla-macosX-100rc2.-1.bin" will create it - with that name).
When this "mozilla-macosX-1.0.0.smi" file is run, even though info says
"classic application", it shows the OS X dialog and create the virtual
disk image.

as of 9:54 am PST, the direct link to the ftp site file is still unavailable.
-> jj
Assignee: seawood → jj
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Summary: macOS X rc2 download broken, is a "classic app" → macOS X rc2 is a "classic app" and will only work if its extension is .smi

Comment 5

16 years ago
Gary: I cannot reproduce the problem intially reported. Downloading OSX rc2 from
either the web site or using the ftp url works just fine for me, and the
downloaded disk image mounts just fine in both cases (under 10.1.2)

Yes, Finder X get info box will show "Classic App" for the .smi file, but that's
normal since they do get built as classic apps. However, Finder X is smart
enough to actually open them with DiskCopy X when you double-click an .smi file,
intead of launching Classic (and resulting in the mount failure you reported).

Regarding you last comment, it's possible that if the file is renamed
'xxx.smi.1', 'xxx.smi.2', etc. during its download because another one with the
same name already exists, then the Finder no longer recognizes the extension of
the file and won't try to open it with DiskCopy X.
Renaming the file 'xxx.smi.1' to 'xxx.1.smi' should suffice to "repair" it and
have it mount properly under X. (I just tried successfully).

Dawn, can this be release notes for the future? -- just say something like "If
the downloaded file opens in the classic environment, make sure its name ends
with '.smi' (with no trailing numbers) and that Disk Copy is present under
/Applications/Utilites/".

-> reassigning to Dawn.
Assignee: jj → endico

Comment 6

16 years ago
*** Bug 146590 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Given that 1.0, 1.0.1, and 1.1 final have all been released, perhaps this bug
should be closed?

Comment 8

16 years ago
Frankie: thanks for asking. I don't see any mention of the issue described in
comment #5 in the release notes or on the download page.
Only when this is fixed can the bug be closed.

Comment 9

15 years ago
I don't see how this is release note worthy. If this was a serious problem then
we'd see scores of duplicates. The number of people likely to encounter this
problem is sufficiently small that I don't think it should be added to the
release notes. 

Comment 10

15 years ago
Although this might not have been reported a lot, I believe it doesn't hurt to
add a single sentence (such as the one suggested in comment #5) to the release
notes about this situation, because I think the average user wouldn't figure out
what to do to resolve the problem without help.

Comment 11

15 years ago
At a minimum, this bug should be renamed, since it has absolutely nothing to do
with 1.0rc2. This is just the way OS X deals with file extensions. If you change
the suffix of ANY .smi file, whether a Mozilla build or an AppleWorks updater,
it becomes a "Classic Application".

Meanwhile, either Finder or Stuffit Expander (or both) has become smarter in the
past 6 months. When extracting a new .smi of the same name as an existing one,
it uses the suffix ".1.smi" instead of ".smi.1" which neatly prevents this problem.

p.s. The entire directory ftp.mozilla.org/pub/mozilla/releases/mozilla1.0rc2/ no
longer exists.

Comment 12

15 years ago
What exactly has to happen in order for this bug to change status? For starters,
this is clearly NOT a blocker -- res ipsa loquitur.

Second, if Asa doesn't want to change the release notes as requested, shouldn't
this be RESOLVED WONTFIX?

Last, at a minimum, the summary really needs to change. It's more like ".SMI
file in OS X becomes 'Classic Application' if you change its suffix". Which as I
said previously has nothing to do with Mozilla in general or 1.0rc2 in particular.

Comment 13

15 years ago
summary & status updated. Happy new year Frankie.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Summary: macOS X rc2 is a "classic app" and will only work if its extension is .smi → OS X blob becomes a 'Classic Application' if its extension (.smi) is changed
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.