Closed Bug 1456449 Opened 4 years ago Closed 2 years ago

Multiple search isn't allowed when Search Bar is moved on Overflow Menu

Categories

(Firefox :: Search, defect, P5)

60 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1490614
Tracking Status
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox73 --- wontfix

People

(Reporter: zstimi, Unassigned)

References

Details

Attachments

(1 file)

Attached video testsearch.mp4
[Affected versions]:
Firefox 59.0.2
Firefox 60.0b14
Firefox 61.0a1

[Affected platforms]:
Ubuntu 14.04 x64
Windows 10 x64
macOS 10.15

[Steps to reproduce]:
1.Launch Firefox.
2.Customize toolbar by drag and drop in overflow menu more than 15 item the including the Search Bar item.  
3.Enter a search term in the Search Bar without pressing Enter.
4.Click on another item from overflow menu (e.g. Forget or History).

[Expected result]:
The Search drop down menu remains in it's position (doesn't jump to the top) and another search can be performed.

[Actual result]:
The drop down menu from search jump to the top, under the address bar and stay there, another search is not allowed and the overflow menu it's still enabled in the background. This happens when the search drop down almost cover the overflow menu.
The video doesn't play. ("Video can't be played because the file is corrupt")

Does this not affect Ubuntu 16.***, only Ubuntu 14.*** ? If so, I'm pretty tempted to suggest wontfix.
Flags: needinfo?(timea.zsoldos)
The video doesn't play in Firefox because of this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1427280 please try to use another application to play it.
Also, the issue is reproduce on Ubuntu 16.04 too.
Flags: needinfo?(timea.zsoldos)
Priority: -- → P5
See Also: → 1454379

I have tested this using 73.0b7 on Windows and macOS 10.15, seems that reproducible on these platforms too.
[Actual result]:
Clicking on "Forget" or "History" (these menus must positioned before the "Search menu" item) the search suggestion drop down appear for a second at the left side of the browser window.

OS: Linux → All
Hardware: x86_64 → All
Summary: [Linux] Multiple search isn't allowed when Search Bar is moved on Overflow Menu → Multiple search isn't allowed when Search Bar is moved on Overflow Menu

bug 1490614 has clearer steps and summary, so duping there.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1490614
You need to log in before you can comment on or make changes to this bug.