MacOS 9 "Sending" window on top, blocking other mozilla windows

VERIFIED DUPLICATE of bug 140844

Status

MailNews Core
Composition
--
minor
VERIFIED DUPLICATE of bug 140844
16 years ago
10 years ago

People

(Reporter: Mabry Tyson, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    1.0RC2  2002051005

When you have clicked on "Send", a window pops up to show the status of the
sending of the message (Sending message.., Delvering mail..., copying to Sent
folder).

In MacOS 9 (but not in MacOS X), this window stays on top of all other Mozilla
windows (browser, mail folders, etc).  If you click on a buried window, it comes
to the top of the other Mozilla windows, but under the pop-up.

If you click on buttons or other clickable items (such as mail messages) while
the "Sending" window is on top, nothing happens.  You can only sit and twiddle
your thumbs until the message is finally delivered.


Reproducible: Always
Steps to Reproduce:
1. Run Mozilla under MacOS 9
2. Compose a mail message (with long attachments would make it more obvious)
3. Click on Send

Actual Results:  "Sending" window pops up on top.  Clicking on other Mozilla
windows results in their being just under the "Sending" window.  Clicking on
buttons in other Mozilla windows is ignored.

Expected Results:  "Sending" window pops up on top.  Clicking on other Mozilla
windows brings them to the top.  Clicking on buttons and other clickable items
in other Mozilla windows is acted upon.

For me, when using the IMAP server at work over a connection from home, this
"Sending" window may be up for quite a while.  For a 1-line message, I just
timed it at 22 seconds in the middle of the night, about 15 seconds of which was
spent copying the message to the Sent folder.

If it matters, I use IMAP and have a copy of messages put in the Sent folder
(probably quite large) on the IMAP server.

All works fine on MacOS X (same server, same user, same 1.0RC2).

This is NOT bug 72489, but it appears that bug 72628 was a similar complaint to
mine (different OS and from long ago) but was marked as a dup of 72489 (possibly
incorrectly IMHO).  

I suppose this form of blocking the UI could have been an easy way out to
satisfy bug 99185 and/or 82120.  But I suspect this blocking was not done
intentionally.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 140844 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.