Crash when setting minimum font size for the first time while visiting Asa's weblog

VERIFIED DUPLICATE of bug 144479

Status

SeaMonkey
Preferences
--
critical
VERIFIED DUPLICATE of bug 144479
16 years ago
7 years ago

People

(Reporter: André Dahlqvist, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
[Build-ID: 2002051907 on Linux]

1. Create a new profile. (Important!)
2. Go to http://www.mozillazine.org/weblogs/asa/
3. Go to Edit->Preferences->Appearance->Fonts
4. Set Minimum Fonts Size to 12.
5. Press OK.

Talkback ID: TB6443943K
(Reporter)

Updated

16 years ago
Severity: normal → critical
Keywords: crash

Comment 1

16 years ago
Seeing this on 1.0 branch 2002051909 too: TB6462264E, no new profile was
needed.

Updated

16 years ago
Keywords: stackwanted

Comment 2

16 years ago
Stack Signature  PL_DHashTableOperate() f93236c7
Product ID MozillaTrunk
Build ID 2002051907
Trigger Time 2002-05-19 11:24:27
Platform LinuxIntel
Operating System Linux 2.4.18
Module libxpcom.so
URL visited http://www.mozillazine.org/weblogs/asa/
User Comments This is 100% reproducable. Steps to reproduce: 1. Create a new
profile. 2. Go to http://www.mozillazine.org/weblogs/asa/ 3. Go to
Edit->Preferences->Appearance->Fonts 4. Set Minimum Fonts Size to 12. 5. Press
OK. Result: Instant crash.
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Source File Name
Trigger Line No.
Stack Trace
PL_DHashTableOperate()
FrameManager::UnregisterPlaceholderFrame()
DoDeletingFrameSubtree()
DeletingFrameSubtree()
nsCSSFrameConstructor::RemoveFixedItems()
nsCSSFrameConstructor::ReconstructDocElementHierarchy()
StyleSetImpl::ReconstructDocElementHierarchy()
PresShell::ReconstructFrames()
PresShell::SetPreferenceStyleRules()
nsPresContext::PreferenceChanged()
nsPresContext::PrefChangedCallback()
pref_DoCallback()
pref_HashPref()
PREF_SetCharPref()
nsPrefBranch::SetCharPref()
nsPrefBranch::SetComplexValue()
nsPrefService::SetComplexValue()
nsPref::SetUnicharPref()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
nsJSContext::CallEventHandler()
GlobalWindowImpl::RunTimeout()
GlobalWindowImpl::TimerCallback()
nsTimerImpl::Fire()
handleTimerEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xee10 (0x40373e10)
libglib-1.2.so.0 + 0x104d8 (0x403754d8)
libglib-1.2.so.0 + 0x10ae3 (0x40375ae3)
libglib-1.2.so.0 + 0x10c7c (0x40375c7c)
libgtk-1.2.so.0 + 0x8d7e7 (0x402967e7)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1914f (0x404b214f)
(Reporter)

Comment 3

16 years ago
Bug 144479 appears to have the same stack, and steps to reproduce are similair.
Duping this one.

*** This bug has been marked as a duplicate of 144479 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.