Closed Bug 145654 Opened 18 years ago Closed 17 years ago

Images on web page keeps loading forever (meta refresh content=";URL=")

Categories

(Core :: DOM: Navigation, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 170021

People

(Reporter: pedro.madeira, Assigned: radha)

References

()

Details

Images on specified web page load normally but when page is done loading all
objects, mozilla restarts page loading. This keeps happening all the time.

Opera loads page only one time.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020519

I forgot to mention the build
<meta http-equiv="refresh" content=";URL=">

!!!
Also occurs on RC2, WinXP...
I can confirm the described behaviour with RC2 on Win2k. (BTW: IE5 does not
reload, but NS4 goes quite crazy reloading all the time)
Given comment #2 => invalid?
(Time to wait before refresh is empty here, so one could interpret it as zero...
I also removed the meta-refresh line from document to eliminate possible other
causes - and everything loaded fine, then)
to docshell in case this is not desired behavior... perhaps we should really
ignore this meta refresh since it seems malformed.
Assignee: darin → adamlock
Component: Networking: HTTP → Embedding: Docshell
QA Contact: tever → adamlock
Assign to Radha.

Meta refresh string is parsed in nsDocShell::SetupRefreshURIFromHeader(). This
meta refresh string is being interpretted as an empty url with a 0 second
refresh. This causes docshell to use the base uri and a 0 second refresh.
Possibly nothing is ever shown because the page keeps being reloaded before it
has a chance to render anything.

The spec for the "refresh" http header is pretty vague but I found a couple of
links. It looks like an Netscape invention to do client side pull so it's not in
the http 1.0 or 1.1 specs.

http://vancouver-webpages.com/META/
http://wp.netscape.com/assist/net_sites/pushpull.html

My guess is we should either:

a) Redo meta refresh to fire once a page finishes loading instead of immediately.
b) Throw away URLs like this - those that don't specify an URL at all or expect
to load themselves immediately.

a) is probably the "right" way but more work.
Assignee: adamlock → radha
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020715

Continues not to work on this build.

The page specified was built on DreamWeaver. So, I don't know if this bug might
happen more often than we suppose.
This is still reproduceable. I'm going to go ahead and confirm this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Did you had the time to confirm this?
Well, he DID confirm it, so it is a NEW bug.

I'm better going to clarify the subject to reflect the bad meta-refresh string
of the page.
(<meta http-equiv="refresh" content=";URL=">)
Summary: Images on web page keeps loading forever → Images on web page keeps loading forever (meta refresh content=";URL=")
Adam, Is this related to the meta-refresh bug that you own. I think there is a
patch to the bug that you own. 
Yes, this looks like a dupe of bug 170021

*** This bug has been marked as a duplicate of 170021 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.