Closed Bug 1456662 Opened 3 years ago Closed 3 years ago

the coverage build says it is an opt build but it is actually a debug build

Categories

(Firefox Build System :: Task Configuration, task)

3 Branch
task
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1457391

People

(Reporter: rforbes, Unassigned)

Details

Attachments

(1 obsolete file)

The current coverage build is labeled as an opt build.

linux64-ccov/opt:
    description: "Linux64-CCov Opt"

This, however, is actually a debug build.

https://dxr.mozilla.org/mozilla-central/source/browser/config/mozconfigs/linux64/code-coverage

This label and description should be changed to debug. I will then make an actual opt coverage build.
FWIW the labels are just that: labels. They mean little to nothing. Same thing for the platform names. The constraint is Treeherder requires us to define a platform name and build type.

We've actually been contemplating consolidating all the build tasks into a single platform so all the build tasks are grouped together and the Treeherder output is more concise (shorter).

But until we have better nomenclature, changing this task to debug to make room for a real opt build feels acceptable. Depending on the downstream consumers of the code coverage data, you may want to land the real opt build at the same time the existing build is renamed, otherwise there may be a gap in coverage. Actually, might might actually be good, since we may want to explicitly modify downstream consumers who were assuming they were getting a debug build.

Things are never easy in the build system :/
Comment on attachment 8973873 [details]
Bug 1456662 - change ccov opt to debug and add an opt build.

https://reviewboard.mozilla.org/r/242234/#review248088


Code analysis found 2 defects in this patch:
 - 2 defects found by mozlint

You can run this analysis locally with:
 - `./mach lint path/to/file` (JS/Python)


If you see a problem in this automated review, please report it here: http://bit.ly/2y9N9Vx


::: taskcluster/taskgraph/transforms/tests.py:683
(Diff revision 1)
>          yield test
>  
>  
>  @transforms.add
>  def enable_code_coverage(config, tests):
> -    """Enable code coverage for the linux64-ccov/opt & linux64-jsdcov/opt & win64-ccov/debug
> +    """Enable code coverage for the linux64-ccov/debug & linux64-ccov/opt & linux64-jsdcov/opt & win64-ccov/debug

Error: Line too long (109 > 99 characters) [flake8: E501]

::: testing/mozharness/configs/builds/releng_sub_linux_configs/64_code_coverage.py:28
(Diff revision 1)
>          'PATH': '/usr/local/bin:/bin:\
>  /usr/bin:/usr/local/sbin:/usr/sbin:/sbin',
>      },
>      'mozconfig_variant': 'code-coverage',
>      #######################
>  }

Error: No newline at end of file [flake8: W292]
Attachment #8973873 - Attachment is obsolete: true
Attachment #8973873 - Flags: review?(gps)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1457391
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.