Closed Bug 1456727 Opened 3 years ago Closed 3 years ago

Intermittent test_ext_webRequest_startup.js | - Stream filter was properly installed for a load during startup - "<!DOCTYPE HTML>\\n\\n<html>\\n<head>\\n<meta charset=\\"utf-8\\">\\n</head>\\n<body>\\n\\n<div id=\\"test\\">

Categories

(WebExtensions :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=175490547&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/f-_mdigIQ6C7AXgMFe6CwQ/runs/0/artifacts/public/logs/live_backing.log

00:11:29     INFO -  PID 6959 | 1524640289350	addons.xpi-utils	DEBUG	Async JSON file read took 0 MS
00:11:29     INFO -  PID 6959 | 1524640289350	addons.xpi-utils	DEBUG	Finished async read of XPI database, parsing...
00:11:29     INFO -  PID 6959 | 1524640289351	addons.xpi-utils	DEBUG	Successfully read XPI database
00:11:29     INFO -  "CONSOLE_MESSAGE: (info) 1524640289350	addons.xpi-utils	DEBUG	Async JSON file read took 0 MS"
00:11:29     INFO -  "CONSOLE_MESSAGE: (info) 1524640289350	addons.xpi-utils	DEBUG	Finished async read of XPI database, parsing..."
00:11:29     INFO -  "CONSOLE_MESSAGE: (info) 1524640289351	addons.xpi-utils	DEBUG	Successfully read XPI database"
00:11:29  WARNING -  TEST-UNEXPECTED-FAIL | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_webRequest_startup.js |  - Stream filter was properly installed for a load during startup - "<!DOCTYPE HTML>\\n\\n<html>\\n<head>\\n<meta charset=\\"utf-8\\">\\n</head>\\n<body>\\n\\n<div id=\\"test\\">Sample text</div>\\n\\n</body>\\n</html>\\n" == "<!DOCTYPE html>\\n<html>\\n<body>\\n  <h1>This is a modified page</h1>\\n</body>\\n</html>"
00:11:29     INFO -  /Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/tests/toolkit/components/extensions/test/xpcshell/test_ext_webRequest_startup.js:null:167
00:11:29     INFO -  exiting test
00:11:29     INFO -  Unexpected exception NS_ERROR_ABORT:
00:11:29     INFO -  _abort_failed_test@/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/head.js:730:9
00:11:29     INFO -  do_report_result@/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/head.js:837:5
00:11:29     INFO -  Assert<@/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/head.js:55:5
00:11:29     INFO -  proto.report@resource://testing-common/Assert.jsm:210:5
00:11:29     INFO -  equal@resource://testing-common/Assert.jsm:242:3
00:11:29     INFO -  @/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/tests/toolkit/components/extensions/test/xpcshell/test_ext_webRequest_startup.js:167:3
00:11:29     INFO -  async*run_next_test/_run_next_test/<@/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/head.js:1425:22
00:11:29     INFO -  async*_run_next_test@/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/head.js:1425:10
00:11:29     INFO -  run@/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/head.js:676:9
00:11:29     INFO -  _do_main@/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/head.js:215:3
00:11:29     INFO -  _execute_test@/Users/cltbld/tasks/task_1524631873/build/tests/xpcshell/head.js:521:5
00:11:29     INFO -  @-e:1:1
00:11:29     INFO -  exiting test
Duplicate of this bug: 1456691
I believe this was fixed between the backout and re-landing of bug 1447551
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.