Closed Bug 1456830 Opened 4 years ago Closed 3 years ago

[Google Maps] The "Earth globe" is not properly rendered after refreshing the webpage

Categories

(Core :: Canvas: WebGL, defect, P3)

x86_64
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- fix-optional

People

(Reporter: emilghitta, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [gfx-noted])

[Affected versions]:
Firefox 61.0a1 (BuildId:20180425100122).
Firefox 60.0b5 (BuildId:20180423171039).
Firefox 59.0.2 (BuildId:20180323154952).

[Unaffected versions]:
Firefox 52.7.3 esr (BuildId:20180322140748).

[Affected platforms]:
macOS 10.13 (Intel Iris Pro 1536).
macOS 10.10.5 (Intel Iris Pro 1536).

[Steps to reproduce]:
1.Launch Firefox.
2.Access the https://www.google.ro/maps website.
3.Change to "Satellite" view.
4.Zoom out until the list of planets are displayed.
5.Refresh the webpage.

[Expected result]:
The Earth is properly rendered.

[Actual result]:
The Earth is not properly rendered.

[Regression range]:
This seems to be a regression:

Last good revision: 767a4bd1abbaf3de1cd2271bc92f0edc29581c9b
First bad revision: 49259b3833d75f094db54b302ac13909a709e0cc

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=767a4bd1abbaf3de1cd2271bc92f0edc29581c9b&tochange=49259b3833d75f094db54b302ac13909a709e0cc

[Additional information]:
For further information regarding this issue please observe the following screencast: https://drive.google.com/open?id=1EcqYctIDdzWbebLGV9zuUNMXcyWK3vy4
Hi Jeff,

It seems that mozregression pointed Bug 1388565.

Could you please have a look? 

Thanks!
Blocks: 1388565
Flags: needinfo?(jgilbert)
Whiteboard: [gfx-noted]

I believe this is fixed now. Is it still broken for you?

Flags: needinfo?(jgilbert) → needinfo?(emil.ghitta)

Hello!
Successfully reproduced the issue using macOS 10.12 with Intel Iris Pro 1536, Firefox 61.0a1(20180425100122) and steps from comment 0.

The issue no longer occurs on Firefox 69.0a1 (20190707211726) using the same gpu.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(emil.ghitta)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.