Closed Bug 1457026 Opened 3 years ago Closed 3 years ago

Display: contents content not copied into the clipboard.

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(2 files)

Attached file Testcase
See the test-case.

Noticed this because of https://bugs.chromium.org/p/chromium/issues/detail?id=830251.

This affects stackoverflow comments.
Flags: needinfo?(emilio)
Attachment #8971085 - Attachment mime type: text/plain → text/html
Assignee: nobody → emilio
Flags: needinfo?(emilio)
Comment on attachment 8971090 [details]
Bug 1457026: Teach nsDocumentEncoder about display: contents.

https://reviewboard.mozilla.org/r/239876/#review245812

::: dom/base/nsDocumentEncoder.cpp:1262
(Diff revision 2)
> +  // FIXME(emilio, bug 1455894): This assumption will probably be wrong in a
> +  // Shadow DOM world...

I think the assumption is already wrong.

::: dom/base/nsDocumentEncoder.cpp:1265
(Diff revision 2)
>    if (!range) {
>      // XXXbz can this happen given rangeCount > 0?
>      return NS_ERROR_NULL_POINTER;
>    }

no, this null-check can be removed
Attachment #8971090 - Flags: review?(mats) → review+
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/422aebe40856
Teach nsDocumentEncoder about display: contents. r=mats
(In reply to Mats Palmgren (:mats) from comment #3)
> Comment on attachment 8971090 [details]
> Bug 1457026: Teach nsDocumentEncoder about display: contents.
> 
> https://reviewboard.mozilla.org/r/239876/#review245812
> 
> ::: dom/base/nsDocumentEncoder.cpp:1262
> (Diff revision 2)
> > +  // FIXME(emilio, bug 1455894): This assumption will probably be wrong in a
> > +  // Shadow DOM world...
> 
> I think the assumption is already wrong.

/me sighs :(
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/36a7b939360d
followup: Skip a rustest that depends on include order and isn't super-useful. r=bholley on a CLOSED TREE
https://hg.mozilla.org/mozilla-central/rev/422aebe40856
https://hg.mozilla.org/mozilla-central/rev/36a7b939360d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Duplicate of this bug: 1452560
You need to log in before you can comment on or make changes to this bug.