Closed Bug 1457066 Opened Last year Closed Last year

[Tab Bar Navigation] Meatball menu should be closed after clicking twice on the meatball button

Categories

(DevTools :: Framework, defect, P3)

61 Branch
defect

Tracking

(firefox61 verified, firefox62 verified)

VERIFIED FIXED
Firefox 62
Tracking Status
firefox61 --- verified
firefox62 --- verified

People

(Reporter: hani.yacoub, Assigned: mantaroh)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

[Affected versions]: 
Nightly 61.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Windows 7 x 64 and Mac OS X 10.13 

[Steps to reproduce]:
1. Open Firefox.
2. Open the Inspector by pressing F12.
3. Click on the meatball menu.
4. Click again on the meatball menu.

[Expected result]:
The menu should be closed after clicking twice on the button.

[Actual result]:
The menu is opened again after clicking twice on the button.
Blocks: 1444299
It's only reproducible on Windows.
Component: Developer Tools → Developer Tools: Framework
Priority: -- → P3
Assignee: nobody → mantaroh
Status: NEW → ASSIGNED
The popup manager will eat click event when clicking outside of popup menu on Mac and Unix.[1][2][3]
However, windows will not eat this event, so the listener of meatball button will be fired. We should add consumeoutesideclicks attribute to this menu popup.

[1] https://searchfox.org/mozilla-central/rev/b28b94dc81d60c6d9164315adbd4a5073526d372/layout/xul/nsMenuPopupFrame.h#195-210
[2] https://searchfox.org/mozilla-central/rev/b28b94dc81d60c6d9164315adbd4a5073526d372/layout/xul/nsMenuPopupFrame.cpp#1772
[3] https://searchfox.org/mozilla-central/rev/b28b94dc81d60c6d9164315adbd4a5073526d372/layout/xul/nsXULPopupManager.cpp#270
Comment on attachment 8973918 [details]
Bug 1457066 - Add consumeoutsideclicks attribute to menu popup.

https://reviewboard.mozilla.org/r/242262/#review248128

Thanks for the patch mantaroh!

This menu is used in the meatballmenu, the chevron menu, the frames menu and serves as context menu for inspector, webconsole and netmonitor.
I quickly tested on Windows 7, couldn't see any issue with them. 

Sometimes the meatball, chevron or frame menus are still redisplayed when clicking on the related button, but that's pretty rare (maybe 10% of time).
Overall this improves the situation so I think we should go ahead and land it.
Attachment #8973918 - Flags: review?(jdescottes) → review+
Comment on attachment 8973918 [details]
Bug 1457066 - Add consumeoutsideclicks attribute to menu popup.

https://reviewboard.mozilla.org/r/242262/#review248128

Thanks Julian!
Pushed by mantaroh@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/36437844d694
Add consumeoutsideclicks attribute to menu popup. r=jdescottes
https://hg.mozilla.org/mozilla-central/rev/36437844d694
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Build ID: 20180508231737
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Verified as fixed on Firefox Nightly 62.0a1 on Windows 10 x 64, Windows 7 x32.
Status: RESOLVED → VERIFIED
Comment on attachment 8973918 [details]
Bug 1457066 - Add consumeoutsideclicks attribute to menu popup.

I'd like to uplift this change to beta.

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: User can't close popup menu when clicking the same position again.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Yes, see the comment 0.
[List of other uplifts needed for the feature/fix]: No
[Is the change risky?]: Not risky, just added a line of XUL attribute, and it only affects Windows. (macOS and Linux doesn't have this bug)
[Why is the change risky/not risky?]: see above.
[String changes made/needed]: N/A
Attachment #8973918 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Comment on attachment 8973918 [details]
Bug 1457066 - Add consumeoutsideclicks attribute to menu popup.

Simple Windows-only fix for closing popups. Approved for 61.0b4.
Attachment #8973918 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Build ID: 20180510160705
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Verified as fixed on Firefox 61.0b4 on Windows 10 x 64, Windows 7 x 32.
Flags: qe-verify+
Duplicate of this bug: 1457070
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.