Closed Bug 1457108 Opened 6 years ago Closed 5 years ago

Address Book does not read vcard 3.0 correctly

Categories

(Thunderbird :: Address Book, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 29106

People

(Reporter: harrie, Unassigned)

References

Details

(Whiteboard: DUPEME)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180327185825

Steps to reproduce:

Select Tools -> Import...
Open file with the following contents:
BEGIN:VCARD
VERSION:3.0
PRODID:-//Sabre//Sabre VObject 4.1.2//EN
UID:a3f9d425-b35c-4779-a9f1-549ad5b65793
FN:First Last
N:Last;First;;Mr.;
TEL;TYPE=HOME:0100 200 300
TEL;CELL:06 100 2000
EMAIL;TYPE=HOME:name@yahoo.com
ADR;TYPE=HOME:;;Street;City;;zip;
REV:20180425T110325Z
END:VCARD



Actual results:

Phone number tagged "TEL;TYPE=HOME" is omitted
Phone number tagged "TEL;CELL" is correctly read and shown when the contact is selected in the contacts listing.


Expected results:

In case of a VERSION 3.0 vcard the correct syntax is "TEL;TYPE=HOME".
In case of a VERSION 2.1 vcard the correct syntax is "TEL;HOME".
Solution:
Address Book must consider the vcard VERSION and interpret the appropriate syntax.
Right. Our address book code is very old and we're lucky of 2.1 is interpreted correctly :-(

Magnus, something to keep in mind for the rewrite.
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(mkmelin+mozilla)
Whiteboard: DUPEME
See Also: → 583572

Issue still exists with Thunderird 60.0.6.1.
vcard 2.1 is fine but if you want to import 3.0 and 4.0, it doesn't import some data fields.

Would TB need to be able to support 2.1 through 4.0 or could 2.1 be dropped in favor of newer versions?

Support for every vCard version would be needed, since they have differences.
The interpretation source code for tags they are in common could be shared.

Luckily this year we'll get a bigger thunderbird update with 3.0 and 4.0 support and other nice stuff.

Oh good, so someone has already taken up the cause. I was going to offer if no one had.

Status: UNCONFIRMED → NEW
Type: defect → task
Component: Untriaged → Address Book
Ever confirmed: true
Version: 52 Branch → unspecified
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.