Crash in mozilla::a11y::Accessible::Bounds

VERIFIED FIXED in Firefox 61

Status

defect
P1
blocker
VERIFIED FIXED
Last year
Last year

People

(Reporter: calixte, Assigned: yzen)

Tracking

(Blocks 1 bug, {crash, regression})

unspecified
Firefox 61
Unspecified
Windows 10
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61blocking verified)

Details

(crash signature)

Attachments

(2 attachments, 2 obsolete attachments)

This bug was filed from the Socorro interface and is
report bp-42d06bc2-f6d1-4c53-9bcb-81abf0180426.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll mozilla::a11y::Accessible::Bounds accessible/generic/Accessible-inl.h:150
1 xul.dll mozilla::a11y::AccessibleWrap::accLocation accessible/windows/msaa/AccessibleWrap.cpp:922
2 xul.dll mozilla::a11y::HandlerProvider::BuildDynamicIA2Data accessible/ipc/win/HandlerProvider.cpp:286
3 xul.dll mozilla::a11y::HandlerProvider::BuildInitialIA2Data accessible/ipc/win/HandlerProvider.cpp:415
4 xul.dll mozilla::detail::RunnableMethodImpl<mozilla::a11y::HandlerProvider*, void  xpcom/threads/nsThreadUtils.h:1216
5 xul.dll mozilla::mscom::MainThreadInvoker::MainThreadAPC ipc/mscom/MainThreadInvoker.cpp:187
6 ntdll.dll RtlDispatchAPC 
7 ntdll.dll KiUserApcDispatch 
8 ntdll.dll NtTestAlert 
9 xul.dll mozilla::SchedulerGroup::Runnable::Run xpcom/threads/SchedulerGroup.cpp:337

=============================================================

There are 12 crashes (from 3 installations) in nightly 61 with buildid 20180426100055. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1450927.

[1] https://hg.mozilla.org/mozilla-central/rev?node=b58c8b754ce2
Flags: needinfo?(yzenevich)
Assignee

Comment 1

Last year
Yes, Looking at it right now.
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Flags: needinfo?(yzenevich)
Assignee

Comment 2

Last year
Posted patch 1457148 patch (obsolete) — Splinter Review
Attachment #8971299 - Flags: review?(surkov.alexander)
Assignee

Comment 3

Last year
Attachment #8971299 - Attachment is obsolete: true
Attachment #8971299 - Flags: review?(surkov.alexander)
Attachment #8971302 - Flags: review?(surkov.alexander)
Comment on attachment 8971302 [details] [diff] [review]
1457148 patch v2

Review of attachment 8971302 [details] [diff] [review]:
-----------------------------------------------------------------

yep, I like this one better!
Attachment #8971302 - Flags: review?(surkov.alexander) → review+

Comment 6

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/2321cd280739
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Reporter

Comment 7

Last year
There still are 147 crashes in nightly with buildid >= 20180427100500.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 61 → ---
Duplicate of this bug: 1457756

Comment 9

Last year
This is still making ff61 unusable for any one running a screen reader.
Assignee

Comment 10

Last year
Posted patch 1457148 part 2 (obsolete) — Splinter Review
Attachment #8972105 - Flags: review?(surkov.alexander)
Comment on attachment 8972105 [details] [diff] [review]
1457148 part 2

Review of attachment 8972105 [details] [diff] [review]:
-----------------------------------------------------------------

r=me but please move out Bounds definition from inl file
Attachment #8972105 - Flags: review?(surkov.alexander) → review+
Assignee

Comment 12

Last year
Carry over r+
Attachment #8972105 - Attachment is obsolete: true
Attachment #8972107 - Flags: review+

Comment 13

Last year
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3ee25bda924e
ensure bounds does not crash for application accessible. r=surkov

Comment 14

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/3ee25bda924e
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
#3 overall top content process crash -> blocking. So far, things are looking good with today's Nightly results, though.
Severity: critical → blocker
Priority: -- → P1

Comment 16

Last year
This is fixt in latest build. Thanks for all your hard work and a quick fix.
Verified fixed on Windows 10 x64 using the latest Nightly 61.0a1(Build ID: 20180501220047).
Status: RESOLVED → VERIFIED

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.