Closed Bug 1457194 Opened 2 years ago Closed 2 years ago

[CSD][Gtk3 < 3.20] Context menu pops up at wrong position after disable titlebar

Categories

(Core :: Widget: Gtk, defect)

61 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox59 --- disabled
firefox60 - unaffected
firefox61 --- fixed

People

(Reporter: alice0775, Assigned: stransky)

References

Details

(Keywords: regression)

Attachments

(5 files)

Attached image screenshot (step2)
Linux Mint 18.3 Mate edition

Reproducible: always

Steps To Reproduce:
1. Disable title bar from customize. and done.
2. Right click on the web page
   ---- observe context menu position
3. Restart browser
4. Right click on the web page
   ---- observe context menu position

Actual Results:
Step2: Context menu pops up at bottom-right corner of screen
Step4: Context menu pops up at top-right corner of screen

Expected Results:
Context menu should pop up at position of mouse pointer
Attached image screenshot (step4)
Attached file about:support
(on Firefox60b15. the context menu popups at slightly left from mouse pointer at step2. --- should be different bug.)
Keywords: regression
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=dfbc948fadaa5455d4a9b0edebd2c7b98f22fb69&tochange=de3a44bd989c495492b95556fec146fdf3a90e50

Regressed by: de3a44bd989c	Martin Stransky — Bug 1441665 - [Gtk] Update window offset explicitly when titlebar is disabled in CSD mode, r=jhorak
Blocks: 1441665
FYI, Bug 1456898 does not fix this problem.
[Tracking Requested - why for this release]:
Assignee: nobody → stransky
Looks like the GetCSDDecorationSize() estimation for Gtk+ < 3.20 does not work well for MATE with old Gtk.
Can you tell me which Gtk3 package version do you have installed?
Flags: needinfo?(alice0775)
(In reply to Martin Stránský [:stransky] from comment #8)
> Can you tell me which Gtk3 package version do you have installed?

$ dpkg -s libgtk-3-0|grep '^Version'
Version: 3.18.9-1ubuntu3.3
Flags: needinfo?(alice0775)
Summary: Context menu pops up at wrong position after disable titlebar → [CSD][Gtk3 < 3.20] Context menu pops up at wrong position after disable titlebar
The patch here disables the offset estimation so effectively reverts Bug 1441665 for Gtk < 3.20.
Comment on attachment 8971532 [details]
Bug 1457194 - Label mShell toplevel window so property_notify_event_cb callback can find its way home,

https://reviewboard.mozilla.org/r/240284/#review246082
Attachment #8971532 - Flags: review?(jhorak) → review+
AIUI this is 61-only, adjusting status for 60.
Comment on attachment 8971531 [details]
Bug 1457194 - [Gtk+\CSD] Don't estimate window offset for Gtk+ < 3.20,

https://reviewboard.mozilla.org/r/240282/#review246084
Attachment #8971531 - Flags: review?(jhorak) → review+
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/921741097e18
[Gtk+\CSD] Don't estimate window offset for Gtk+ < 3.20, r=jhorak
https://hg.mozilla.org/integration/autoland/rev/9c7060496264
Label mShell toplevel window so property_notify_event_cb callback can find its way home, r=jhorak
(In reply to Alice0775 White from comment #3)
> (on Firefox60b15. the context menu popups at slightly left from mouse
> pointer at step2. --- should be different bug.)

I filed Bug 1457438.
https://hg.mozilla.org/mozilla-central/rev/921741097e18
https://hg.mozilla.org/mozilla-central/rev/9c7060496264
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.