repainting slowdown when hidden tabs have content loaded

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Andreas Schrattenecker, Assigned: jag (Peter Annema))

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020518
BuildID:    mozilla RC2+ 2002051806

when you have more tabs open with content loaded, it slows down
repainting mozilla( i.e. resizing mozilla, resizing sidebar), although
only one tab is visible. im not talking about some % slowdown, but some
x00% slowdown. it looks like all hidden tabs are getting repainted too?
 

Reproducible: Always
Steps to Reproduce:
1. open http://www.mozilla.org/
2. open 4 empty tabs
3. go to first tab(www.mozilla.org loaded)
4. resize mozilla, resize sidebar (watch the speed mozilla gets repainted)
5. fill the 4 empty tabs with i.e.:
   http://bugzilla.mozilla.org/show_bug.cgi?id=108938
   http://bugzilla.mozilla.org/show_bug.cgi?id=138000
   http://bugzilla.mozilla.org/show_bug.cgi?id=134771
   http://bugzilla.mozilla.org/show_bug.cgi?id=143200
6. go to first tab(www.mozilla.org loaded)
7. when all tabs are loaded resize mozilla (sidebar) again

Actual Results:  repainting mozilla gets alot slower

Expected Results:  repainting should not decrease much

tested using:
windows 2000, SP2, mozilla RC2+ 2002051806, PIII@700MHz 
linux, suse 8.0, mozilla RC2, Athlon@800MHz

Updated

16 years ago
Keywords: perf
(Reporter)

Comment 1

16 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → pmac

Comment 2

15 years ago
I have the similar problem, after long intensive work(typycal a half day) with
tabs mozilla slows down. Only restart of mozilla help. I can't reproduce it.
Running with KDE 3.1. Culd not reporoduce above steps.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030714 Debian/1.4-2

Updated

15 years ago
Depends on: 227361
(Reporter)

Comment 3

14 years ago
not reproducible anymore with firefox 1.0 (regardless how complex the pages are
loaded in hidden tabs, redraw is very fast for visible tab, as fast like when
other tabs woulndt have been loaded)

still reproducible with mozilla 1.7.3

tested using fedora core 3.

Comment 4

13 years ago
WFM - FF 1.5 and seamonkey using steps in comment 0
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.