Closed Bug 1457379 Opened 2 years ago Closed 1 year ago

WebSockets show only under 'other'

Categories

(DevTools :: Netmonitor, defect, P3)

61 Branch
defect

Tracking

(firefox61 wontfix, firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox61 --- wontfix
firefox68 --- fixed

People

(Reporter: drno, Assigned: Laphets)

References

Details

Attachments

(1 file, 1 obsolete file)

When trying to look at the WebSocket in a Slack tab and choosing to limit the network tab in dev-tools to 'WS' only it shows nothing.

If I choose 'other' instead I see a bunch of WebSockets.

This looks like wrong labeling of WebSockets in the network tab of dev-tools.
I can confirm, this is a bug.
Thanks for the report!
Honza
Priority: -- → P3
Duplicate of this bug: 1459942
See bug 1459942 for detailed STR and a screencast.
Product: Firefox → DevTools
Duplicate of this bug: 1512695

Would like to contribute for this bug :)

Assigned to you, thanks for the help!
Honza

Assignee: nobody → wenqing4
Status: NEW → ASSIGNED

Thanks for the update!
See my comment in phabricator! (looks good, we need a test)

Honza

Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/51ec0da695a4
[Adding Tests] Fix webSockets show only under 'other' filter. r=Honza
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Attachment #9048242 - Attachment is obsolete: true
Duplicate of this bug: 1557806
You need to log in before you can comment on or make changes to this bug.