Closed Bug 1457401 Opened 2 years ago Closed 2 years ago

[@ mozilla::net::HttpBaseChannel::MaybeReportTimingData ] crash

Categories

(Core :: DOM: Core & HTML, defect)

61 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- verified

People

(Reporter: Oriol, Assigned: dragana)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

Enter this code into browser console:

  var ioService = Components.classes["@mozilla.org/network/io-service;1"].getService(Ci.nsIIOService);
  var uri = ioService.newURI("http://example.com", null, null);
  var channel = ioService.newChannelFromURI2(uri, null, null, null, null, null);
  channel.QueryInterface(Ci.nsIHttpChannel);
  channel.asyncOpen({}, null);

Result: crash (null deref)

Crash report: https://crash-stats.mozilla.com/report/index/85f872bf-011d-45cd-bf86-33f570180427

Regression window: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c7f6d061d06ca85fcb8e54946cd90ceb93a604d1&tochange=fa8202661c163cf890873b2d6979db1a6917bebc
There are 2 crashes (from 1 installation) in nightly 61 with buildid 20180426100055. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1423495.

[1] https://hg.mozilla.org/mozilla-central/rev?node=11804549931f
Blocks: clouseau
Has STR: --- → yes
Component: Networking: HTTP → DOM
Flags: needinfo?(valentin.gosu)
Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED
Attachment #8971551 - Flags: review?(valentin.gosu)
remove asyncOpen! :)
Comment on attachment 8971551 [details] [diff] [review]
bug_1457401.patch

Review of attachment 8971551 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the quick fix :D
Attachment #8971551 - Flags: review?(valentin.gosu) → review+
Flags: needinfo?(valentin.gosu)
Keywords: checkin-needed
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f846639066aa
Check if loadInfo is present. r=valentin
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f846639066aa
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
No more crashes since the patch landed.
Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.