[MATE, Gtk < 3.20] Context menu pops up at slightly left from the mouse pointer after disable titlebar

RESOLVED DUPLICATE of bug 1456452

Status

()

defect
RESOLVED DUPLICATE of bug 1456452
a year ago
8 months ago

People

(Reporter: alice0775, Unassigned)

Tracking

(Blocks 1 bug)

60 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(thunderbird_esr52 unaffected, firefox-esr52 unaffected, firefox-esr60 affected, firefox59 disabled, firefox60 affected, firefox61 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Posted video screencast
+++ This bug was initially created as a clone of Bug #1457194 +++

Linux Mint 18.3 Mate edition

Reproducible: always

Steps To Reproduce:
1. Disable title bar from customize. and done.
2. Right click on the web page
   ---- observe context menu position

Actual Results:
Context menu pops up at slightly left. i.e., the position is back button.

Expected Results:
Context menu should pop up at position of mouse pointer. i.e., the corner of context menu should be as same as the mouse pointer.

When Enable titlebar, the problem is gone.
(Reporter)

Updated

11 months ago
Blocks: 283299
(Reporter)

Comment 1

11 months ago
I can still reprodice the problem on the Nightly62.0a1.

Build ID 	20180514220126
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
(Reporter)

Comment 2

11 months ago
s/reprodice/reproduce/
Yes, it's because code path for Gtk < 3.20 here.
Blocks: gtktitlebar
No longer blocks: 283299
Summary: Context menu pops up at slightly left from the mouse pointer after disable titlebar → [MATE, Gtk < 3.20] Context menu pops up at slightly left from the mouse pointer after disable titlebar
This is a dupe of Bug 1456452. Unfortunately I'm not sure how to fix that correctly on Gtk+ < 3.20 as we can only approximate it.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1456452
You need to log in before you can comment on or make changes to this bug.