download manager should go away

VERIFIED INVALID

Status

VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: bernd_mozilla, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
at least after the download has finished. The old download manager had a
checkmark to close automatically after the download finished. Where has this
checkmark gone? How could such a regression (lost functionality) pass the review
process?
Below follows a typical #mozilla discussion about the panel....

1>so what's up with this download manager window?
1>why do we need something like that
1 doesn't see the point
2->1: some do
1->for what
1 is just annoyed by it
2->1: so switch it off
1->where?
2->1: one sec
3->1: The point is to get rid of the annoying individual progress windows
4->1: file a bug that you would like to have a pref on front panel against blake
2->1: user_pref(("browser.downloadmanager.behavior", [0/1/2]);

Comment 1

17 years ago
Embedding a new menu option under 'Tools>Download Manager' so that you can
either start the download manager or disable the download manager would be nice.
 With a disabled download manager, downloads should work as they did before. 
This should exist on all platforms.
*** Bug 146050 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
I completely agree with Patrick.  When MS introduced a download manager for
their MacOS IE flavour - I found it quite annoying.  Having the ability to
choose the old method would definitely be nice.

Voting for the ability to disable the download manager.

Comment 4

17 years ago
I have just noticed that in my build (2002061208), Mozilla has an option in
Preferences under Navigator -> Downloads to determine how to handle downloads. 
Simply select "Open a progress dialog" for the old method.  Very nice.
(Reporter)

Comment 5

17 years ago
due to hixie the old progress bar is back, and with that the checkmark, no
regression any more.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
mass-verification of Invalid bugs.

if you don't think the report is invalid, please check to see if it has already
been reported (it might be a duplicate instead). otherwise, make sure that there
are steps (a valid test case) that clearly display the issue as an unexpected
defect.

mail filter string for bugspam: SequoiadendronGiganteum
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.