If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

cursor doesn't move from beginning of line in url bar

RESOLVED FIXED

Status

SeaMonkey
Location Bar
--
minor
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: Jeff Jennings, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    1.0rc2

the displayed cursor (vertical bar) in the url bar doesn't move in response to
mouse positioning or cursor key positioning.  the actual cursor position does
change, i can hit the right arrow key 3 times and then the delete key, and the
correct character in the url text is deleted.  but the displayed cursor is still
at the beginning of the text.

Reproducible: Always
Steps to Reproduce:
1.get some text in the url bar
2.try to position the cursor (hit right arrow a few times)
3.note cursor position, still at beginning of text

i've only tested 2 platforms (3 computers).  the problem occurs on 2 linux
machines, both running Mandrake Linux 8.2, one running KDE 3.0 and one running
XFCE desktops.  on a windows 2000 machine, the problem does not occur.
(Reporter)

Comment 1

16 years ago
problem doesn't occur running redhat7.3/kde3.0

Comment 2

16 years ago
I can confirm this. I believe this is a subset of the behaviour of bug 145213,
and therefore a duplicate of that bug.
(Reporter)

Comment 3

16 years ago
fixed with new compile of mozilla 1.0rc2, using gcc 3.1-1 package on Mandrake
Linux , which has a fix for a memset problem in gcc.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.