Intermittent Android-bustage java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is:

RESOLVED FIXED in Firefox 61

Status

defect
P5
normal
RESOLVED FIXED
Last year
Last month

People

(Reporter: intermittent-bug-filer, Assigned: jchen)

Tracking

({intermittent-failure})

unspecified
mozilla61

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(2 attachments)

Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=176246991&repo=try

https://queue.taskcluster.net/v1/task/BzAIWAGVQNSO4GXK-lMwOw/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-30T11:02:08.234Z] 11:02:08     INFO -  Using Kotlin incremental compilation
[task 2018-04-30T11:02:11.886Z] 11:02:11     INFO -  :geckoview_example:transformDexArchiveWithExternalLibsDexMergerForOfficialWithGeckoBinariesNoMinApiDebugAndroidTest
[task 2018-04-30T11:02:11.978Z] 11:02:11     INFO -  :geckoview_example:transformDexArchiveWithDexMergerForOfficialWithGeckoBinariesNoMinApiDebugAndroidTest
[task 2018-04-30T11:02:12.110Z] 11:02:12     INFO -  :geckoview_example:transformResourcesWithMergeJavaResForOfficialWithGeckoBinariesNoMinApiDebugAndroidTest
[task 2018-04-30T11:02:19.622Z] 11:02:19     INFO -  e: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is:
[task 2018-04-30T11:02:19.622Z] 11:02:19     INFO -  	java.io.EOFException
[task 2018-04-30T11:02:19.622Z] 11:02:19     INFO -  	at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:236)
[task 2018-04-30T11:02:19.623Z] 11:02:19     INFO -  	at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:161)
[task 2018-04-30T11:02:19.623Z] 11:02:19     INFO -  	at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:227)
[task 2018-04-30T11:02:19.624Z] 11:02:19     INFO -  	at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:179)
[task 2018-04-30T11:02:19.624Z] 11:02:19     INFO -  	at com.sun.proxy.$Proxy104.clearJarCache(Unknown Source)
[task 2018-04-30T11:02:19.624Z] 11:02:19     INFO -  	at org.jetbrains.kotlin.compilerRunner.GradleCompilerRunner.compileWithDaemon(GradleKotlinCompilerRunner.kt:216)
[task 2018-04-30T11:02:19.624Z] 11:02:19     INFO -  	at org.jetbrains.kotlin.compilerRunner.GradleCompilerRunner.compileWithDaemonOrFallback(GradleKotlinCompilerRunner.kt:156)
[task 2018-04-30T11:02:19.625Z] 11:02:19     INFO -  	at org.jetbrains.kotlin.compilerRunner.GradleCompilerRunner.compileWithDaemonOrFallback(GradleKotlinCompilerRunner.kt:52)
[task 2018-04-30T11:02:19.625Z] 11:02:19     INFO -  	at org.jetbrains.kotlin.compilerRunner.KotlinCompilerRunner.runCompiler(KotlinCompilerRunner.kt:127)
[task 2018-04-30T11:02:19.625Z] 11:02:19     INFO -  	at org.jetbrains.kotlin.compilerRunner.GradleCompilerRunner.runJvmCompiler(GradleKotlinCompilerRunner.kt:107)
[task 2018-04-30T11:02:19.626Z] 11:02:19     INFO -  	at org.jetbrains.kotlin.gradle.tasks.KotlinCompile.callCompiler$kotlin_gradle_plugin(Tasks.kt:326)
[task 2018-04-30T11:02:19.626Z] 11:02:19     INFO -  	at org.jetbrains.kotlin.gradle.tasks.KotlinCompile.callCompiler$kotlin_gradle_plugin(Tasks.kt:231)
[task 2018-04-30T11:02:19.627Z] 11:02:19     INFO -  	at org.jetbrains.kotlin.gradle.tasks.AbstractKotlinCompile.execute(Tasks.kt:203)
[task 2018-04-30T11:02:19.627Z] 11:02:19     INFO -  	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[task 2018-04-30T11:02:19.627Z] 11:02:19     INFO -  	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
[task 2018-04-30T11:02:19.627Z] 11:02:19     INFO -  	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
[task 2018-04-30T11:02:19.627Z] 11:02:19     INFO -  	at java.lang.reflect.Method.invoke(Method.java:498)
[task 2018-04-30T11:02:19.627Z] 11:02:19     INFO -  	at org.gradle.internal.reflect.JavaMethod.invoke(JavaMethod.java:73)
[task 2018-04-30T11:02:19.628Z] 11:02:19     INFO -  	at org.gradle.api.internal.project.taskfactory.DefaultTaskClassInfoStore$IncrementalTaskAction.doExecute(DefaultTaskClassInfoStore.java:173)
[task 2018-04-30T11:02:19.628Z] 11:02:19     INFO -  	at org.gradle.api.internal.project.taskfactory.DefaultTaskClassInfoStore$StandardTaskAction.execute(DefaultTaskClassInfoStore.java:134)
[task 2018-04-30T11:02:19.628Z] 11:02:19     INFO -  	at org.gradle.api.internal.project.taskfactory.DefaultTaskClassInfoStore$StandardTaskAction.execute(DefaultTaskClassInfoStore.java:121)
[task 2018-04-30T11:02:19.628Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter$1.run(ExecuteActionsTaskExecuter.java:122)
[task 2018-04-30T11:02:19.629Z] 11:02:19     INFO -  	at org.gradle.internal.progress.DefaultBuildOperationExecutor$RunnableBuildOperationWorker.execute(DefaultBuildOperationExecutor.java:336)
[task 2018-04-30T11:02:19.629Z] 11:02:19     INFO -  	at org.gradle.internal.progress.DefaultBuildOperationExecutor$RunnableBuildOperationWorker.execute(DefaultBuildOperationExecutor.java:328)
[task 2018-04-30T11:02:19.629Z] 11:02:19     INFO -  	at org.gradle.internal.progress.DefaultBuildOperationExecutor.execute(DefaultBuildOperationExecutor.java:197)
[task 2018-04-30T11:02:19.629Z] 11:02:19     INFO -  	at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:107)
[task 2018-04-30T11:02:19.630Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeAction(ExecuteActionsTaskExecuter.java:111)
[task 2018-04-30T11:02:19.630Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:92)
[task 2018-04-30T11:02:19.630Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.execute(ExecuteActionsTaskExecuter.java:70)
[task 2018-04-30T11:02:19.630Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.SkipUpToDateTaskExecuter.execute(SkipUpToDateTaskExecuter.java:63)
[task 2018-04-30T11:02:19.630Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.ResolveTaskOutputCachingStateExecuter.execute(ResolveTaskOutputCachingStateExecuter.java:54)
[task 2018-04-30T11:02:19.631Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.ValidatingTaskExecuter.execute(ValidatingTaskExecuter.java:58)
[task 2018-04-30T11:02:19.631Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.SkipEmptySourceFilesTaskExecuter.execute(SkipEmptySourceFilesTaskExecuter.java:88)
[task 2018-04-30T11:02:19.631Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.ResolveTaskArtifactStateTaskExecuter.execute(ResolveTaskArtifactStateTaskExecuter.java:52)
[task 2018-04-30T11:02:19.631Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.SkipTaskWithNoActionsExecuter.execute(SkipTaskWithNoActionsExecuter.java:52)
[task 2018-04-30T11:02:19.632Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.SkipOnlyIfTaskExecuter.execute(SkipOnlyIfTaskExecuter.java:54)
[task 2018-04-30T11:02:19.632Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.ExecuteAtMostOnceTaskExecuter.execute(ExecuteAtMostOnceTaskExecuter.java:43)
[task 2018-04-30T11:02:19.632Z] 11:02:19     INFO -  	at org.gradle.api.internal.tasks.execution.CatchExceptionTaskExecuter.execute(CatchExceptionTaskExecuter.java:34)
[task 2018-04-30T11:02:19.632Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker$1.run(DefaultTaskGraphExecuter.java:248)
[task 2018-04-30T11:02:19.632Z] 11:02:19     INFO -  	at org.gradle.internal.progress.DefaultBuildOperationExecutor$RunnableBuildOperationWorker.execute(DefaultBuildOperationExecutor.java:336)
[task 2018-04-30T11:02:19.633Z] 11:02:19     INFO -  	at org.gradle.internal.progress.DefaultBuildOperationExecutor$RunnableBuildOperationWorker.execute(DefaultBuildOperationExecutor.java:328)
[task 2018-04-30T11:02:19.633Z] 11:02:19     INFO -  	at org.gradle.internal.progress.DefaultBuildOperationExecutor.execute(DefaultBuildOperationExecutor.java:197)
[task 2018-04-30T11:02:19.633Z] 11:02:19     INFO -  	at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:107)
[task 2018-04-30T11:02:19.633Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker.execute(DefaultTaskGraphExecuter.java:241)
[task 2018-04-30T11:02:19.634Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker.execute(DefaultTaskGraphExecuter.java:230)
[task 2018-04-30T11:02:19.634Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskPlanExecutor$TaskExecutorWorker.processTask(DefaultTaskPlanExecutor.java:124)
[task 2018-04-30T11:02:19.634Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskPlanExecutor$TaskExecutorWorker.access$200(DefaultTaskPlanExecutor.java:80)
[task 2018-04-30T11:02:19.634Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskPlanExecutor$TaskExecutorWorker$1.execute(DefaultTaskPlanExecutor.java:105)
[task 2018-04-30T11:02:19.635Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskPlanExecutor$TaskExecutorWorker$1.execute(DefaultTaskPlanExecutor.java:99)
[task 2018-04-30T11:02:19.635Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskExecutionPlan.execute(DefaultTaskExecutionPlan.java:625)
[task 2018-04-30T11:02:19.635Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskExecutionPlan.executeWithTask(DefaultTaskExecutionPlan.java:580)
[task 2018-04-30T11:02:19.635Z] 11:02:19     INFO -  	at org.gradle.execution.taskgraph.DefaultTaskPlanExecutor$TaskExecutorWorker.run(DefaultTaskPlanExecutor.java:99)
[task 2018-04-30T11:02:19.635Z] 11:02:19     INFO -  	at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:63)
[task 2018-04-30T11:02:19.636Z] 11:02:19     INFO -  	at org.gradle.internal.concurrent.ManagedExecutorImpl$1.run(ManagedExecutorImpl.java:46)
[task 2018-04-30T11:02:19.636Z] 11:02:19     INFO -  	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
[task 2018-04-30T11:02:19.636Z] 11:02:19     INFO -  	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
[task 2018-04-30T11:02:19.636Z] 11:02:19     INFO -  	at org.gradle.internal.concurrent.ThreadFactoryImpl$ManagedThreadRunnable.run(ThreadFactoryImpl.java:55)
[task 2018-04-30T11:02:19.636Z] 11:02:19     INFO -  	at java.lang.Thread.run(Thread.java:748)
[task 2018-04-30T11:02:19.637Z] 11:02:19     INFO -  Caused by: java.io.EOFException
[task 2018-04-30T11:02:19.637Z] 11:02:19     INFO -  	at java.io.DataInputStream.readByte(DataInputStream.java:267)
[task 2018-04-30T11:02:19.637Z] 11:02:19     INFO -  	at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:222)
[task 2018-04-30T11:02:19.637Z] 11:02:19     INFO -  	... 57 more
[task 2018-04-30T11:02:19.637Z] 11:02:19     INFO -  e: Compiler terminated with internal error
[task 2018-04-30T11:02:19.638Z] 11:02:19     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiDebugAndroidTestKotlin FAILED
[task 2018-04-30T11:02:19.638Z] 11:02:19     INFO -  :geckoview:generateOfficialWithGeckoBinariesNoMinApiDebugAndroidTestSources
[task 2018-04-30T11:02:19.638Z] 11:02:19     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiDebugAndroidTestNdk NO-SOURCE
[task 2018-04-30T11:02:19.642Z] 11:02:19     INFO -  :geckoview:mergeOfficialWithGeckoBinariesNoMinApiDebugAndroidTestShaders
[task 2018-04-30T11:02:19.642Z] 11:02:19     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiDebugAndroidTestShaders
[task 2018-04-30T11:02:19.642Z] 11:02:19     INFO -  :geckoview:generateOfficialWithGeckoBinariesNoMinApiDebugAndroidTestAssets
[task 2018-04-30T11:02:19.977Z] 11:02:19     INFO -  :geckoview:mergeOfficialWithGeckoBinariesNoMinApiDebugAndroidTestAssets
[task 2018-04-30T11:02:19.977Z] 11:02:19     INFO -  :geckoview:mergeOfficialWithGeckoBinariesNoMinApiDebugAndroidTestJniLibFolders
[task 2018-04-30T11:02:19.987Z] 11:02:19     INFO -  :geckoview:transformNativeLibsWithIntermediateJniLibsForOfficialWithGeckoBinariesNoMinApiDebug
[task 2018-04-30T11:02:19.987Z] 11:02:19     INFO -  :geckoview:transformNativeLibsWithMergeJniLibsForOfficialWithGeckoBinariesNoMinApiDebugAndroidTest
[task 2018-04-30T11:02:20.058Z] 11:02:20     INFO -  :geckoview_example:transformNativeLibsWithMergeJniLibsForOfficialWithGeckoBinariesNoMinApiDebug
[task 2018-04-30T11:02:20.186Z] 11:02:20     INFO -  :geckoview_example:packageOfficialWithGeckoBinariesNoMinApiDebug
[task 2018-04-30T11:02:20.186Z] 11:02:20     INFO -  :geckoview:processOfficialWithGeckoBinariesNoMinApiDebugAndroidTestJavaRes NO-SOURCE
[task 2018-04-30T11:02:20.186Z] 11:02:20     INFO -  :geckoview:validateSigningOfficialWithGeckoBinariesNoMinApiDebugAndroidTest
[task 2018-04-30T11:02:20.186Z] 11:02:20     INFO -  :geckoview:preOfficialWithGeckoBinariesNoMinApiReleaseBuild UP-TO-DATE
[task 2018-04-30T11:02:20.251Z] 11:02:20     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiReleaseAidlaidl E 04-30 11:02:20 72954 72954 aidl.cpp:580] refusing to generate code from aidl file defining parcelable
[task 2018-04-30T11:02:20.271Z] 11:02:20     INFO -  aidl E 04-30 11:02:20 72978 72978 aidl.cpp:580] refusing to generate code from aidl file defining parcelable
[task 2018-04-30T11:02:20.272Z] 11:02:20     INFO -  aidl E 04-30 11:02:20 72984 72984 aidl.cpp:580] refusing to generate code from aidl file defining parcelable
[task 2018-04-30T11:02:20.281Z] 11:02:20     INFO -  aidl E 04-30 11:02:20 72990 72990 aidl.cpp:580] refusing to generate code from aidl file defining parcelable
[task 2018-04-30T11:02:20.302Z] 11:02:20     INFO -  aidl E 04-30 11:02:20 73019 73019 aidl.cpp:580] refusing to generate code from aidl file defining parcelable
[task 2018-04-30T11:02:20.302Z] 11:02:20     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiReleaseNdk NO-SOURCE
[task 2018-04-30T11:02:20.312Z] 11:02:20     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiReleaseRenderscript
[task 2018-04-30T11:02:20.312Z] 11:02:20     INFO -  :geckoview:checkOfficialWithGeckoBinariesNoMinApiReleaseManifest
[task 2018-04-30T11:02:20.312Z] 11:02:20     INFO -  :geckoview:generateOfficialWithGeckoBinariesNoMinApiReleaseBuildConfig
[task 2018-04-30T11:02:20.312Z] 11:02:20     INFO -  :geckoview:generateOfficialWithGeckoBinariesNoMinApiReleaseResValues
[task 2018-04-30T11:02:20.313Z] 11:02:20     INFO -  :geckoview:generateOfficialWithGeckoBinariesNoMinApiReleaseResources
[task 2018-04-30T11:02:20.322Z] 11:02:20     INFO -  :geckoview:packageOfficialWithGeckoBinariesNoMinApiReleaseResources
[task 2018-04-30T11:02:20.332Z] 11:02:20     INFO -  :geckoview:processOfficialWithGeckoBinariesNoMinApiReleaseManifest
[task 2018-04-30T11:02:20.363Z] 11:02:20     INFO -  :geckoview:processOfficialWithGeckoBinariesNoMinApiReleaseResources
[task 2018-04-30T11:02:20.383Z] 11:02:20     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiReleaseKotlin
[task 2018-04-30T11:02:20.384Z] 11:02:20     INFO -  :geckoview:generateOfficialWithGeckoBinariesNoMinApiReleaseSources
[task 2018-04-30T11:02:20.384Z] 11:02:20     INFO -  :geckoview:javaPreCompileOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:22.682Z] 11:02:22     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiReleaseJavaWithJavac
[task 2018-04-30T11:02:22.682Z] 11:02:22     INFO -  :geckoview_example:assembleOfficialWithGeckoBinariesNoMinApiDebug
[task 2018-04-30T11:02:22.793Z] 11:02:22     INFO -  :geckoview_example:transformNativeLibsWithMergeJniLibsForOfficialWithGeckoBinariesNoMinApiDebugAndroidTest
[task 2018-04-30T11:02:22.946Z] 11:02:22     INFO -  :geckoview_example:packageOfficialWithGeckoBinariesNoMinApiDebugAndroidTest
[task 2018-04-30T11:02:22.946Z] 11:02:22     INFO -  :geckoview_example:assembleOfficialWithGeckoBinariesNoMinApiDebugAndroidTest
[task 2018-04-30T11:02:23.138Z] 11:02:23     INFO -  Note: Some input files use or override a deprecated API.
[task 2018-04-30T11:02:23.139Z] 11:02:23     INFO -  Note: Recompile with -Xlint:deprecation for details.
[task 2018-04-30T11:02:23.139Z] 11:02:23     INFO -  Note: /builds/worker/workspace/build/src/mobile/android/geckoview/src/main/java/org/mozilla/gecko/gfx/PanZoomController.java uses unchecked or unsafe operations.
[task 2018-04-30T11:02:23.139Z] 11:02:23     INFO -  Note: Recompile with -Xlint:unchecked for details.
[task 2018-04-30T11:02:23.554Z] 11:02:23     INFO -  :geckoview:extractOfficialWithGeckoBinariesNoMinApiReleaseAnnotations
[task 2018-04-30T11:02:23.554Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.RuntimeTelemetry.SnapshotType: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.564Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.LoadFlags: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.574Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.ProgressDelegate.SecurityInformation.SecurityMode: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.575Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.ProgressDelegate.SecurityInformation.ContentType: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.575Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.ContentDelegate.ElementType: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.575Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.SelectionActionDelegate.Flag: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.575Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.SelectionActionDelegate.Action: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.576Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.SelectionActionDelegate.HideReason: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.576Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.NavigationDelegate.TargetWindow: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.576Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.NavigationDelegate.LoadRequestFlags: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.576Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.PromptDelegate.AuthOptions.AuthFlag: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.576Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.PromptDelegate.AuthOptions.AuthLevel: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.577Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.PromptDelegate.Choice.ChoiceType: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.577Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.PromptDelegate.DatetimeType: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.584Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.PromptDelegate.FileType: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.585Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.TrackingProtectionDelegate.Category: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.585Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.PermissionDelegate.Permission: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.585Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.PermissionDelegate.MediaSource.Source: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.585Z] 11:02:23     INFO -  Warning: org.mozilla.geckoview.GeckoSession.PermissionDelegate.MediaSource.Type: The typedef annotation should have @Retention(RetentionPolicy.SOURCE)
[task 2018-04-30T11:02:23.919Z] 11:02:23     INFO -  :geckoview:processOfficialWithGeckoBinariesNoMinApiReleaseJavaRes NO-SOURCE
[task 2018-04-30T11:02:24.061Z] 11:02:24     INFO -  :geckoview:transformClassesAndResourcesWithPrepareIntermediateJarsForOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:24.061Z] 11:02:24     INFO -  :geckoview:generateJNIWrappersForGeneratedOfficialWithGeckoBinariesNoMinApiReleasePicked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf-8
[task 2018-04-30T11:02:24.112Z] 11:02:24     INFO -  Processing annotations...
[task 2018-04-30T11:02:24.587Z] 11:02:24     INFO -  Annotation processing complete in 469ms
[task 2018-04-30T11:02:24.608Z] 11:02:24     INFO -  :geckoview:mergeOfficialWithGeckoBinariesNoMinApiReleaseShaders
[task 2018-04-30T11:02:24.608Z] 11:02:24     INFO -  :geckoview:compileOfficialWithGeckoBinariesNoMinApiReleaseShaders
[task 2018-04-30T11:02:24.932Z] 11:02:24     INFO -  :geckoview:syncAssetsFromDistDirForOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:24.942Z] 11:02:24     INFO -  :geckoview:syncLibsFromDistDirForOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:24.952Z] 11:02:24     INFO -  :geckoview:syncOmnijarFromDistDirForOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:24.952Z] 11:02:24     INFO -  :geckoview:generateOfficialWithGeckoBinariesNoMinApiReleaseAssets
[task 2018-04-30T11:02:25.266Z] 11:02:25     INFO -  :geckoview:mergeOfficialWithGeckoBinariesNoMinApiReleaseAssets
[task 2018-04-30T11:02:25.266Z] 11:02:25     INFO -  :geckoview:mergeOfficialWithGeckoBinariesNoMinApiReleaseConsumerProguardFiles
[task 2018-04-30T11:02:25.266Z] 11:02:25     INFO -  :geckoview:packageOfficialWithGeckoBinariesNoMinApiReleaseRenderscript NO-SOURCE
[task 2018-04-30T11:02:25.317Z] 11:02:25     INFO -  :geckoview:transformResourcesWithMergeJavaResForOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:25.469Z] 11:02:25     INFO -  :geckoview:transformClassesAndResourcesWithSyncLibJarsForOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:25.479Z] 11:02:25     INFO -  :geckoview:mergeOfficialWithGeckoBinariesNoMinApiReleaseJniLibFolders
[task 2018-04-30T11:02:25.489Z] 11:02:25     INFO -  :geckoview:transformNativeLibsWithMergeJniLibsForOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:25.499Z] 11:02:25     INFO -  :geckoview:transformNativeLibsWithSyncJniLibsForOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:29.536Z] 11:02:29     INFO -  :geckoview:bundleOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:30.042Z] 11:02:30     INFO -  :geckoview:javadocOfficialWithGeckoBinariesNoMinApiReleasePicked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf-8
[task 2018-04-30T11:02:32.078Z] 11:02:32     INFO -  :geckoview:javadocJarOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:32.240Z] 11:02:32     INFO -  :geckoview:sourcesJarOfficialWithGeckoBinariesNoMinApiRelease
[task 2018-04-30T11:02:32.959Z] 11:02:32     INFO -  :geckoview:uploadArchivesCould not find metadata org.mozilla:geckoview-beta-arm64-v8a/maven-metadata.xml in remote (file:///builds/worker/workspace/build/src/obj-firefox/gradle/build/mobile/android/geckoview/maven)
[task 2018-04-30T11:02:32.969Z] 11:02:32     INFO -  FAILURE: Build failed with an exception.
[task 2018-04-30T11:02:32.969Z] 11:02:32     INFO -  * What went wrong:
[task 2018-04-30T11:02:32.969Z] 11:02:32     INFO -  Execution failed for task ':geckoview:compileOfficialWithGeckoBinariesNoMinApiDebugAndroidTestKotlin'.
[task 2018-04-30T11:02:32.970Z] 11:02:32     INFO -  > Internal compiler error. See log for more details
[task 2018-04-30T11:02:32.970Z] 11:02:32     INFO -  * Try:
[task 2018-04-30T11:02:32.970Z] 11:02:32     INFO -  Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
[task 2018-04-30T11:02:32.979Z] 11:02:32     INFO -  * Get more help at https://help.gradle.org
[task 2018-04-30T11:02:32.979Z] 11:02:32     INFO -  BUILD FAILED in 43s
[task 2018-04-30T11:02:32.980Z] 11:02:32     INFO -  123 actionable tasks: 110 executed, 13 up-to-date
[task 2018-04-30T11:02:33.672Z] 11:02:33    ERROR - Return code: 1
[task 2018-04-30T11:02:33.673Z] 11:02:33    ERROR - 1 not in success codes: [0]
[task 2018-04-30T11:02:33.673Z] 11:02:33  WARNING - setting return code to 2
[task 2018-04-30T11:02:33.673Z] 11:02:33    FATAL - Halting on failure while running ['/usr/bin/python2.7', 'mach', '--log-no-times', 'android', 'archive-geckoview']
[task 2018-04-30T11:02:33.673Z] 11:02:33    FATAL - Running post_fatal callback...
This was for a central-as-beta simulation.
jchen: over to you?
Flags: needinfo?(nchen)
Looks like a kotlin bug that was fixed in 1.2.20 [1]. We should probably update our kotlin version.

[1] https://youtrack.jetbrains.com/issue/KT-17601
Flags: needinfo?(nchen)
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Comment on attachment 8972390 [details]
Bug 1457863 - 1. Update kotlin to 1.2.41;

https://reviewboard.mozilla.org/r/241010/#review246792

Fine by me.  sebastian is a better reviewer for Kotlin stuff, since he follows the ecosystem more closely than I do.
Attachment #8972390 - Flags: review?(nalexander) → review+
Comment on attachment 8972391 [details]
Bug 1457863 - 2. Use kotlin array literals;

https://reviewboard.mozilla.org/r/241012/#review246794

Sure.  Again, sebastian might have an opinion on syntax.  Can this be linted/checkstyled to ensure one style in the codebase?
Attachment #8972391 - Flags: review+
Sebastian, how does Focus handle Kotlin version updates? Any issues you've ran into while updating Kotlin?
Flags: needinfo?(s.kaspari)
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d4e8c9ea8f0e
1. Update kotlin to 1.2.20; r=nalexander
https://hg.mozilla.org/integration/autoland/rev/a9e4a1af13b9
2. Use kotlin array literals; r=nalexander
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6340700abe0f
Backed out 2 changesets for merge conflict on a CLOSED TREE
On second thought I decided to update kotlin to 1.2.41 because that's the current version. It seems Android Studio only offers the option of updating its own kotlin plugin to the latest version, so if GV uses a non-current version, there will be a mismatch between GV and Android Studio when it comes to kotlin version.
Flags: needinfo?(nchen)
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/65c4d7d9eab2
1. Update kotlin to 1.2.41; r=nalexander
https://hg.mozilla.org/integration/autoland/rev/fd6be860e542
2. Use kotlin array literals; r=nalexander
https://hg.mozilla.org/mozilla-central/rev/65c4d7d9eab2
https://hg.mozilla.org/mozilla-central/rev/fd6be860e542
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
(In reply to Jim Chen [:jchen] [:darchons] from comment #8)
> Sebastian, how does Focus handle Kotlin version updates? Any issues you've
> ran into while updating Kotlin?

We update to the latest version frequently. There have been no issues so far. There's a quite good documentation about what kind of compatibility is guaranteed:
http://kotlinlang.org/docs/reference/compatibility.html
Flags: needinfo?(s.kaspari)
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 61 → mozilla61
You need to log in before you can comment on or make changes to this bug.