Closed Bug 1457872 Opened Last year Closed Last year

Intermittent mozdevice.adb.ADBProcessError: args: adb -s emulator-5554 wait-for-device shell am force-stop org.mozilla.fennec_aurora; echo rc=$?, exitcode: 137, stdout: Killed

Categories

(Firefox for Android :: Testing, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: gbrown)

References

Details

(Keywords: intermittent-failure)

Filed by: rgurzau [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=176263830&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/VQmyWfYmQLSn8dx8jWsyGg/runs/0/artifacts/public/logs/live_backing.log

[task 2018-04-30T12:16:56.971Z] 12:16:56     INFO - >> Install app APK: Attempt #1 of 3
[task 2018-04-30T12:16:56.971Z] 12:16:56     INFO - Running timeout 300 /builds/worker/workspace/build/android-sdk-linux/platform-tools/adb -s emulator-5554 install -r /builds/worker/workspace/build/target.apk
[task 2018-04-30T12:17:38.346Z] 12:17:38     INFO - Finished installing apps for test-1
[task 2018-04-30T12:17:38.346Z] 12:17:38     INFO - Running post-action listener: _resource_record_post_action
[task 2018-04-30T12:17:38.347Z] 12:17:38     INFO - [mozharness: 2018-04-30 12:17:38.347026Z] Finished install step (success)
[task 2018-04-30T12:17:38.347Z] 12:17:38     INFO - [mozharness: 2018-04-30 12:17:38.347248Z] Running run-tests step.
[task 2018-04-30T12:17:38.347Z] 12:17:38     INFO - Running pre-action listener: _resource_record_pre_action
[task 2018-04-30T12:17:38.348Z] 12:17:38     INFO - Running pre-action listener: _set_gcov_prefix
[task 2018-04-30T12:17:38.348Z] 12:17:38     INFO - Running main action method: run_tests
[task 2018-04-30T12:17:38.348Z] 12:17:38     INFO - Running command: ['unzip', '-q', '-o', '/builds/worker/workspace/build/target.apk'] in /builds/worker/workspace/build
[task 2018-04-30T12:17:38.349Z] 12:17:38     INFO - Copy/paste: unzip -q -o /builds/worker/workspace/build/target.apk
[task 2018-04-30T12:17:38.767Z] 12:17:38     INFO - Return code: 0
[task 2018-04-30T12:17:38.768Z] 12:17:38     INFO - Reading from file /builds/worker/workspace/build/package-name.txt
[task 2018-04-30T12:17:38.768Z] 12:17:38     INFO - Contents:
[task 2018-04-30T12:17:38.768Z] 12:17:38     INFO -  org.mozilla.fennec_aurora
[task 2018-04-30T12:17:38.769Z] 12:17:38     INFO - Running on test-1 the command /builds/worker/workspace/build/venv/bin/python -u /builds/worker/workspace/build/tests/mochitest/runtestsremote.py --app=org.mozilla.fennec_aurora --remote-webserver=10.0.2.2 --xre-path=/builds/worker/workspace/build/hostutils/host-utils-61.0a1.en-US.linux-x86_64 --utility-path=/builds/worker/workspace/build/hostutils/host-utils-61.0a1.en-US.linux-x86_64 --certificate-path=/builds/worker/workspace/build/tests/certs --symbols-path=/builds/worker/workspace/build/symbols --quiet --log-raw=/builds/worker/workspace/build/blobber_upload_dir/mochitest_raw.log --log-errorsummary=/builds/worker/workspace/build/blobber_upload_dir/mochitest_errorsummary.log --extra-profile-file=fonts --extra-profile-file=hyphenation --screenshot-on-fail --this-chunk 2 --total-chunks 48
[task 2018-04-30T12:17:38.769Z] 12:17:38     INFO - ##### mochitest log begins
[task 2018-04-30T12:17:38.770Z] 12:17:38     INFO - Running command: ['/builds/worker/workspace/build/venv/bin/python', '-u', '/builds/worker/workspace/build/tests/mochitest/runtestsremote.py', '--app=org.mozilla.fennec_aurora', '--remote-webserver=10.0.2.2', '--xre-path=/builds/worker/workspace/build/hostutils/host-utils-61.0a1.en-US.linux-x86_64', '--utility-path=/builds/worker/workspace/build/hostutils/host-utils-61.0a1.en-US.linux-x86_64', '--certificate-path=/builds/worker/workspace/build/tests/certs', '--symbols-path=/builds/worker/workspace/build/symbols', '--quiet', '--log-raw=/builds/worker/workspace/build/blobber_upload_dir/mochitest_raw.log', '--log-errorsummary=/builds/worker/workspace/build/blobber_upload_dir/mochitest_errorsummary.log', '--extra-profile-file=fonts', '--extra-profile-file=hyphenation', '--screenshot-on-fail', '--this-chunk', '2', '--total-chunks', '48'] in /builds/worker/workspace/build/tests/mochitest
[task 2018-04-30T12:17:38.771Z] 12:17:38     INFO - Copy/paste: /builds/worker/workspace/build/venv/bin/python -u /builds/worker/workspace/build/tests/mochitest/runtestsremote.py --app=org.mozilla.fennec_aurora --remote-webserver=10.0.2.2 --xre-path=/builds/worker/workspace/build/hostutils/host-utils-61.0a1.en-US.linux-x86_64 --utility-path=/builds/worker/workspace/build/hostutils/host-utils-61.0a1.en-US.linux-x86_64 --certificate-path=/builds/worker/workspace/build/tests/certs --symbols-path=/builds/worker/workspace/build/symbols --quiet --log-raw=/builds/worker/workspace/build/blobber_upload_dir/mochitest_raw.log --log-errorsummary=/builds/worker/workspace/build/blobber_upload_dir/mochitest_errorsummary.log --extra-profile-file=fonts --extra-profile-file=hyphenation --screenshot-on-fail --this-chunk 2 --total-chunks 48
[task 2018-04-30T12:17:38.772Z] 12:17:38     INFO - Using env: {'ANDROID_AVD_HOME': '/builds/worker/workspace/build/.android/avd',
[task 2018-04-30T12:17:38.773Z] 12:17:38     INFO -  'ANDROID_SDK_HOME': '/builds/worker/workspace/build',
[task 2018-04-30T12:17:38.773Z] 12:17:38     INFO -  'DISPLAY': ':0.0',
[task 2018-04-30T12:17:38.773Z] 12:17:38     INFO -  'ENABLE_E10S': 'false',
[task 2018-04-30T12:17:38.773Z] 12:17:38     INFO -  'GECKO_BASE_REPOSITORY': 'https://hg.mozilla.org/mozilla-unified',
[task 2018-04-30T12:17:38.774Z] 12:17:38     INFO -  'GECKO_HEAD_REPOSITORY': 'https://hg.mozilla.org/integration/mozilla-inbound',
[task 2018-04-30T12:17:38.774Z] 12:17:38     INFO -  'GECKO_HEAD_REV': '7ac16ce8810c3550ae107b3fe872d45e6fccc45b',
[task 2018-04-30T12:17:38.775Z] 12:17:38     INFO -  'HG_STORE_PATH': '/builds/worker/checkouts/hg-store',
[task 2018-04-30T12:17:38.775Z] 12:17:38     INFO -  'HOME': '/builds/worker',
[task 2018-04-30T12:17:38.775Z] 12:17:38     INFO -  'HOSTNAME': 'taskcluster-worker',
[task 2018-04-30T12:17:38.775Z] 12:17:38     INFO -  'LANG': 'en_US.UTF-8',
[task 2018-04-30T12:17:38.775Z] 12:17:38     INFO -  'LC_ALL': 'en_US.UTF-8',
[task 2018-04-30T12:17:38.775Z] 12:17:38     INFO -  'LD_LIBRARY_PATH': '/builds/worker/workspace/build',
[task 2018-04-30T12:17:38.775Z] 12:17:38     INFO -  'LOGNAME': 'worker',
[task 2018-04-30T12:17:38.776Z] 12:17:38     INFO -  'MINIDUMP_SAVEPATH': '/builds/worker/workspace/build/../minidumps',
[task 2018-04-30T12:17:38.776Z] 12:17:38     INFO -  'MINIDUMP_SAVE_PATH': '/builds/worker/workspace/build/blobber_upload_dir',
[task 2018-04-30T12:17:38.776Z] 12:17:38     INFO -  'MINIDUMP_STACKWALK': '/usr/local/bin/linux64-minidump_stackwalk',
[task 2018-04-30T12:17:38.776Z] 12:17:38     INFO -  'MOCHITEST_FLAVOR': 'plain',
[task 2018-04-30T12:17:38.777Z] 12:17:38     INFO -  'MOZHARNESS_ACTIONS': 'get-secrets',
[task 2018-04-30T12:17:38.777Z] 12:17:38     INFO -  'MOZHARNESS_CONFIG': 'android/android_common.py android/androidarm_4_3.py',
[task 2018-04-30T12:17:38.777Z] 12:17:38     INFO -  'MOZHARNESS_SCRIPT': 'android_emulator_unittest.py',
[task 2018-04-30T12:17:38.778Z] 12:17:38     INFO -  'MOZHARNESS_URL': 'https://queue.taskcluster.net/v1/task/Yn2yDIDwQSaziMJQFy8lRQ/artifacts/public/build/mozharness.zip',
[task 2018-04-30T12:17:38.778Z] 12:17:38     INFO -  'MOZILLA_BUILD_URL': 'https://queue.taskcluster.net/v1/task/Yn2yDIDwQSaziMJQFy8lRQ/artifacts/public/build/target.apk',
[task 2018-04-30T12:17:38.778Z] 12:17:38     INFO -  'MOZ_AUTOMATION': '1',
[task 2018-04-30T12:17:38.779Z] 12:17:38     INFO -  'MOZ_SOURCE_CHANGESET': '7ac16ce8810c3550ae107b3fe872d45e6fccc45b',
[task 2018-04-30T12:17:38.779Z] 12:17:38     INFO -  'MOZ_SOURCE_REPO': 'https://hg.mozilla.org/integration/mozilla-inbound',
[task 2018-04-30T12:17:38.779Z] 12:17:38     INFO -  'MOZ_UPLOAD_DIR': '/builds/worker/workspace/build/blobber_upload_dir',
[task 2018-04-30T12:17:38.780Z] 12:17:38     INFO -  'NEED_PULSEAUDIO': 'true',
[task 2018-04-30T12:17:38.780Z] 12:17:38     INFO -  'NEED_WINDOW_MANAGER': 'true',
[task 2018-04-30T12:17:38.780Z] 12:17:38     INFO -  'OLDPWD': '/builds/worker/workspace',
[task 2018-04-30T12:17:38.780Z] 12:17:38     INFO -  'PATH': '/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/builds/worker/bin:/builds/worker/workspace/build/android-sdk-linux/tools:/builds/worker/workspace/build/android-sdk-linux/platform-tools',
[task 2018-04-30T12:17:38.780Z] 12:17:38     INFO -  'PWD': '/builds/worker/workspace',
[task 2018-04-30T12:17:38.780Z] 12:17:38     INFO -  'RELENGAPI_NAME': '/frosty_yonath/relengapi',
[task 2018-04-30T12:17:38.780Z] 12:17:38     INFO -  'RELENGAPI_PORT': 'tcp://172.17.0.3:80',
[task 2018-04-30T12:17:38.781Z] 12:17:38     INFO -  'RELENGAPI_PORT_80_TCP': 'tcp://172.17.0.3:80',
[task 2018-04-30T12:17:38.781Z] 12:17:38     INFO -  'RELENGAPI_PORT_80_TCP_ADDR': '172.17.0.3',
[task 2018-04-30T12:17:38.781Z] 12:17:38     INFO -  'RELENGAPI_PORT_80_TCP_PORT': '80',
[task 2018-04-30T12:17:38.781Z] 12:17:38     INFO -  'RELENGAPI_PORT_80_TCP_PROTO': 'tcp',
[task 2018-04-30T12:17:38.781Z] 12:17:38     INFO -  'RUN_ID': '0',
[task 2018-04-30T12:17:38.781Z] 12:17:38     INFO -  'RUST_BACKTRACE': 'full',
[task 2018-04-30T12:17:38.781Z] 12:17:38     INFO -  'SCCACHE_DISABLE': '1',
[task 2018-04-30T12:17:38.781Z] 12:17:38     INFO -  'SHELL': '/bin/bash',
[task 2018-04-30T12:17:38.782Z] 12:17:38     INFO -  'SHLVL': '1',
[task 2018-04-30T12:17:38.782Z] 12:17:38     INFO -  'TASKCLUSTER_INSTANCE_TYPE': 'c3.xlarge',
[task 2018-04-30T12:17:38.782Z] 12:17:38     INFO -  'TASKCLUSTER_NAME': '/frosty_yonath/taskcluster',
[task 2018-04-30T12:17:38.782Z] 12:17:38     INFO -  'TASKCLUSTER_PORT': 'tcp://172.17.0.2:80',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TASKCLUSTER_PORT_80_TCP': 'tcp://172.17.0.2:80',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TASKCLUSTER_PORT_80_TCP_ADDR': '172.17.0.2',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TASKCLUSTER_PORT_80_TCP_PORT': '80',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TASKCLUSTER_PORT_80_TCP_PROTO': 'tcp',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TASKCLUSTER_PUBLIC_IP': '13.57.10.32',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TASKCLUSTER_WORKER_GROUP': 'us-west-1',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TASKCLUSTER_WORKER_TYPE': 'gecko-t-linux-xlarge',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TASK_ID': 'VQmyWfYmQLSn8dx8jWsyGg',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TERM': 'xterm',
[task 2018-04-30T12:17:38.783Z] 12:17:38     INFO -  'TOOLTOOL_CACHE': '/builds/worker/tooltool-cache',
[task 2018-04-30T12:17:38.784Z] 12:17:38     INFO -  'USER': 'worker'}
[task 2018-04-30T12:17:39.230Z] 12:17:39     INFO -  adb adbd running as root
[task 2018-04-30T12:17:39.334Z] 12:17:39     INFO -  adb su -c supported
[task 2018-04-30T12:17:39.437Z] 12:17:39     INFO -  adb su 0 supported
[task 2018-04-30T12:17:39.645Z] 12:17:39     INFO -  adb /system/bin/ls -a supported
[task 2018-04-30T12:17:39.748Z] 12:17:39     INFO -  adb Native cp support: True
[task 2018-04-30T12:17:39.853Z] 12:17:39     INFO -  adb Native chmod -R support: True
[task 2018-04-30T12:17:39.956Z] 12:17:39     INFO -  adb Setting SELinux Permissive Mode
[task 2018-04-30T12:17:40.060Z] 12:17:40     INFO -  adb Unable to set SELinux Permissive due to args: adb -s emulator-5554 wait-for-device shell setenforce Permissive; echo rc=$?, exitcode: 1, stdout: setenforce: SELinux is disabled.
[task 2018-04-30T12:17:45.052Z] 12:17:45     INFO -  Traceback (most recent call last):
[task 2018-04-30T12:17:45.053Z] 12:17:45     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtestsremote.py", line 377, in <module>
[task 2018-04-30T12:17:45.053Z] 12:17:45     INFO -      sys.exit(main())
[task 2018-04-30T12:17:45.053Z] 12:17:45     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtestsremote.py", line 373, in main
[task 2018-04-30T12:17:45.053Z] 12:17:45     INFO -      return run_test_harness(parser, options)
[task 2018-04-30T12:17:45.053Z] 12:17:45     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtestsremote.py", line 341, in run_test_harness
[task 2018-04-30T12:17:45.054Z] 12:17:45     INFO -      mochitest = MochiRemote(options)
[task 2018-04-30T12:17:45.055Z] 12:17:45     INFO -    File "/builds/worker/workspace/build/tests/mochitest/runtestsremote.py", line 95, in __init__
[task 2018-04-30T12:17:45.056Z] 12:17:45     INFO -      self.device.stop_application(procName)
[task 2018-04-30T12:17:45.057Z] 12:17:45     INFO -    File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/mozdevice/adb_android.py", line 527, in stop_application
[task 2018-04-30T12:17:45.057Z] 12:17:45     INFO -      timeout=timeout, root=root)
[task 2018-04-30T12:17:45.058Z] 12:17:45     INFO -    File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/mozdevice/adb.py", line 1195, in shell_output
[task 2018-04-30T12:17:45.058Z] 12:17:45     INFO -      raise ADBProcessError(adb_process)
[task 2018-04-30T12:17:45.059Z] 12:17:45     INFO -  mozdevice.adb.ADBProcessError: args: adb -s emulator-5554 wait-for-device shell am force-stop org.mozilla.fennec_aurora; echo rc=$?, exitcode: 137, stdout: Killed
[task 2018-04-30T12:17:45.071Z] 12:17:45    ERROR - Return code: 1
[task 2018-04-30T12:17:45.072Z] 12:17:45    ERROR - No tests run or test summary not found
Assignee: nobody → gbrown
Duplicate of this bug: 1457878
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d2014da1a457
Add one more error to mozharness retry list; r=me,a=test-only
https://hg.mozilla.org/mozilla-central/rev/d2014da1a457
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
You need to log in before you can comment on or make changes to this bug.