Closed Bug 14579 Opened 21 years ago Closed 20 years ago

A popup window that should expand open doesn't finish its expansion

Categories

(Core Graveyard :: GFX, defect, P3)

PowerPC
Mac System 8.6
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: reboughner, Assigned: kmcclusk)

Details

Attachments

(1 file)

The example file has an explanation window that should expand open whien the
cursor passes over the shield image.  It starts to expand but only the first
part of this window is shown properly; the remainder of the window does appear.
This example manipulates the clip property of the hidden window and the dump
statements show that the steps to do the expansion are being executed but the
window doesn't fully appear.  This example was done using a nightly build
ID#1999091713
This example works fine in IE5.0.
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Seems to work okay with the latest build.

I know this didn't work, so I'm going to mark it FIXED (and not WORKSFORME), but
I don't know what specific change(s) caused it to start working
It doesn't work with the M10 build on a Windows 98 machine which is the latest
build that I have downloaded.
I'm sure it doesn't work with M10. That build is probably a month old, and lots
has changed since then
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
With the Nov 15th Linux and Windows builds, the problem has been fixed. On the
Mac Nov 15 build, the problem still remains. The entire window is displayed
instead of the clipped portion.
Assignee: troy → beard
Status: REOPENED → NEW
Component: Layout → Compositor
OS: Windows 98 → Mac System 8.6
Changing bug to be Mac specific, and reassigning since if it works everywhere
but Mac it probably isn't a layout bug
I downloaded the windows M11 build of Gecko and tried this example on it and the
popup still doesn't fully expand open.  All that I get is the lower right hand
corner of the popup.  If I bypass the expand function and set Top and Left to
zero then the popup window shows completely.  Is there some difference between
the M11 build and the builds that you used to verify that the problem was fixed
on a Windows platform?
Status: NEW → ASSIGNED
I get exactly the same behavior as described on the Mac build. I'd guess either
DOM setting of the clipRect isn't working, or the view manager's interpretation
of the clipRect is wrong. If I comment all code out that sets the clipRect of the
style of the layer, then it shows up completely.
You did notice that I mentioned that I was having this problem on a Windows 98
machine with the M11 build. This was after it had been reassigned to be a MAC
specific problem.
A few additional comments concerning this bug.  I've done some more
experimentation on it with the M11 build on a Windows 98 machine.  First, I can
set the clipping to anything that I want and when the mouse passes over the
graphic it shows up as expected as long as I don't call the expand function in
the code.
Second, change the visibility rule in the #shield rule to visible and add the
following rule: clip: rect(125px, 0px, 0px, 250px);  This should make the expand
div invisible but when the page is first rendered the region that will be
occupied by the expanded shield is shown but it has the background of the
underlying browser window which goes away as soon as the mouse passes over the
graphic but it still doesn't fully expand.
Target Milestone: M15
Reassigning all compositor bugs to kevin.
Assignee: beard → kmcclusk
Status: ASSIGNED → NEW
This is not a MAC specific bug.  It still doesn't work in the M14 build on a 
Windows 98 machine.
Status: NEW → ASSIGNED
Bulk moving to M16
Target Milestone: M15 → M16
Moving to M17
Target Milestone: M16 → M17
Fixed in 5/5/2000 build on WINNT.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
I don't think this is completely fixed.  It works in almost all cases.  But try 
moving your pointer into the graphic from the left side where the hidden window 
will expand out.  The mouse movements interfere with the window expansion.  

Another thing to try is continually moving your mouse around right in front of 
the lion's mouth.  The window expansion continually re-starts.

To me, this doesn't seem like the desired behavior.  I think this bug should be 
re-opened.
Marking verified in the May 30th builds.
Status: RESOLVED → VERIFIED
Hardware: PC → Macintosh
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.