Closed Bug 1457933 Opened 2 years ago Closed 2 years ago

No longer possible to selectively delete cookies for a site

Categories

(Firefox :: Page Info Window, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1457935

People

(Reporter: bzbarsky, Unassigned)

References

Details

(Keywords: regression)

Bug 1348223 removed the cookie viewer/deletion UI from page info.  The commit says:

   Equivalent functionality in a well-maintained interface can be
   found in the storage manager or the devtools storage inspector.

which is not true at all.  In particular, the page info UI let me select a subset of cookies for a site and delete those.  The devtools storage inspector is readonly, and the storage manager has per-site granularity, not per-cookie.  Now that my nightly has updated, I've lost the ability to selectively delete cookies, as far as I can tell.
Go bugzilla, creating a bug and then pretending it didn't....
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1457935
Looks like the devtools storage inspector _can_ in fact delete cookies.  Via a context menu, not keyboard.  And you can't select the cookies you want to delete; you have to delete them one at a time.   So it's not really usable for what I was using the page info UI for.
You need to log in before you can comment on or make changes to this bug.