Closed Bug 1458066 Opened Last year Closed Last year

Implement ability to move a selection of tabs within the same window through drag and drop

Categories

(Firefox :: Tabbed Browser, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed
firefox64 --- verified
firefox65 --- verified

People

(Reporter: ablayelyfondou, Assigned: ablayelyfondou, Mentored)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Follow up for bug 1458056
Status: UNCONFIRMED → NEW
Ever confirmed: true
Does this feature affect to the WebExtensions API: browser.tabs.move()? When
one of multiselected tab is specified, all multiselected tabs should be moved also?
Please do not duplicate comments. I have responded to your comment in bug 1458049.
Bug 1458056 seems to be for dragging out to a new window, so should this bug be for existing windows including the same window? Or is that a separate bug to track dragging multiple tabs across windows?
(In reply to Ed Lee :Mardak (PTO July 7-22) from comment #3)
> Bug 1458056 seems to be for dragging out to a new window, so should this bug
> be for existing windows including the same window? Or is that a separate bug
> to track dragging multiple tabs across windows?

This bug (1458066) is for dragging within the same window only. This action should move all selected tabs to be placed next to each other first (moving the selected tabs towards the tab that is being dragged), and then slide the selected tabs as one unit through the tab strip.

Bug 1458056 is for dragging out to create a new window as well as dropping in a pre-existing window. Neither of these actions includes an animation. Instead they show a dropmarker where the tabs would be inserted.
Blocks: 1477796
Blocks: 1479257
Comment on attachment 8995611 [details]
Bug 1458066 - Implement ability to move a selection of tabs within the same window through drag and drop.

https://reviewboard.mozilla.org/r/260018/#review267170

Setting r- because this current patch has the jumping of the selected but not-foreground tabs during dragging.
Attachment #8995611 - Flags: review?(jaws) → review-
Patch updated but WIP for tests.
Flags: needinfo?(jaws)
Comment on attachment 8995611 [details]
Bug 1458066 - Implement ability to move a selection of tabs within the same window through drag and drop.

https://reviewboard.mozilla.org/r/260018/#review267556

Looks good, thanks!

You can reference /browser/base/content/test/general/browser_tabReorder.js for your tests.
Attachment #8995611 - Flags: review?(jaws) → review+
Flags: needinfo?(jaws)
Comment on attachment 8995611 [details]
Bug 1458066 - Implement ability to move a selection of tabs within the same window through drag and drop.

https://reviewboard.mozilla.org/r/260018/#review267646

Test looks good. I'll push this to tryserver now.
Assignee: nobody → ablayelyfondou
Status: NEW → ASSIGNED
There are failures on the trypush in browser/base/content/test/general/browser_tabDrop.js

TypeError: draggedTab is undefined at onxbldrop@chrome://browser/content/tabbrowser.xml:1399:13
sendDragEvent@chrome://mochikit/content/tests/SimpleTest/EventUtils.js:263:10
synthesizeDropAfterDragOver@chrome://mochikit/content/tests/SimpleTest/EventUtils.js:2654:5
synthesizeDrop@chrome://mochikit/content/tests/SimpleTest/EventUtils.js:2701:12
drop@chrome://mochitests/content/browser/browser/base/content/test/general/browser_tabDrop.js:176:3
async*dropText@chrome://mochitests/content/browser/browser/base/content/test/general/browser_tabDrop.js:150:10
single_url@chrome://mochitests/content/browser/browser/base/content/test/general/browser_tabDrop.js:23:9
Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1103:34
async*Tester_execTest@chrome://mochikit/content/browser-test.js:1094:16
nextTest/<@chrome://mochikit/content/browser-test.js:996:9
SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
Flags: needinfo?(ablayelyfondou)
Flags: needinfo?(ablayelyfondou)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f4a038da1903
Implement ability to move a selection of tabs within the same window through drag and drop. r=jaws
https://hg.mozilla.org/mozilla-central/rev/f4a038da1903
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Verified fixed that this implementation is present on the latest Nightly Nightly 65.0a1(2018-11-22)and the latest Beta 64.0b11 as well .
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.