If no key entered, next dialog does not make sense in context

VERIFIED INVALID

Status

P3
minor
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: cpratt, Assigned: morse)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999092208
Platform: all

To reproduce:
- Launch apprunner
- Go to a site with a login (eg my.netscape.com)
- Enter the info requested and send it to the server
- At this point wallet / single signon takes over. Eventually you are asked to
enter a key *OR* to leave the input field blank.

Result: If you opt to leave it blank, another dialog comes up that asks you to
'confirm your key'. Logically, you went for the OR condition of a key; that is,
NO key. Therefore, you can't confirm your key because you have no key. I would
instead expect this dialog to be skipped if you opted for NO key.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 1

19 years ago
Although I agree with you, it could be argued that even the empty password
should be confirmed.  What if the user thought that he entered a
single-character password but his finger slipped and he didn't enter any
characters.  The confirmation would catch that error.

But it's all academic anyway.  The use of two dialog boxes (one asking for
password and the second asking for confirmation) is hopefully temporary.  It
will be dropped if davidm provides us with a single dialog containg two password
fields.

So based on these arguments, I am closing the bug report out as invalid.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
agreed, this will hopefully be a moot point
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.