Status

MailNews Core
Security: S/MIME
--
critical
VERIFIED WONTFIX
16 years ago
9 years ago

People

(Reporter: Chris Mark, Assigned: Stephane Saux)

Tracking

1.0 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When I try to send a mail message through my SMTP server at mail.speakeasy.org I 
get an error message that "You cannpt connect to mail.speakeasy.org because SSL 
is disabled." followed by "Sending of message failed. The message could not be 
sent because connecting to the SMTP server failed. The server may be unavailable 
or is refusing SMTP connections. Please verify that your SMTP server setting is 
correct and try again, or else contact your network administrator."

I have checked the Preferences settings and they all indicate that SSL is 
enabled. I also get a message about permissions on the Preferences folder, but 
that also appears to be OK.

My Netscape 4.79 and Outlook Express mail clients both work fine.
Reporter: Can you visit https pages like https://www.ccc.de ?
->PSM. Do we support connecting to mail servers via SSL?
Assignee: mstoltz → ssaux
Component: Security: General → S/MIME
Product: MailNews → PSM
QA Contact: junruh → carosendahl
Version: other → 2.3

Comment 3

16 years ago
Reporter,

I just tried from within Netscape (obviously relaying is not turned off at
mail.speakeasy.net) and successfully sent mail messages over SMTP/SSL and SMTP.

However, I see a warning indicating that mail.speakeasy.org is an alias for
mail.speakeasy.net ... continue anyway? (impostor dialog).  After accepting,
mail goes through and is received by me at my netscape account.

I would check the following conditions:
1.  Are you going through proxies and are they set up on the other clients
2.  How does it work if you connect to mail.speakeasy.net instead of
mail.speakeasy.org
3.  Verify the the SSL settings are set on both server settings and outgoing
server.  Verify that SMTP port is blanked out.

Let me know if you still have the problem after trying these things so we can
close this or pursue it further.

Comment 4

16 years ago
Turned out this was a problem in mrigration of profiles - for whatever reason,
the secmod db file wasn't working with NS7.0.  After deleting secmod.db, the
client worked as designed.

PSM can't actually fix this, and profile migration most likely needs a
utility/architectural change to correct all bugs of this nature.  So this bug is
closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 5

16 years ago
.
Status: RESOLVED → VERIFIED

Updated

13 years ago
Component: Security: S/MIME → Security: S/MIME
Product: PSM → Core

Updated

10 years ago
Version: psm2.3 → 1.0 Branch

Updated

9 years ago
Component: Security: S/MIME → Security: S/MIME
Product: Core → MailNews Core
QA Contact: carosendahl → s.mime
You need to log in before you can comment on or make changes to this bug.