Closed Bug 1458384 Opened Last year Closed Last year

Can't cancel new contact dialog

Categories

(Thunderbird :: Address Book, defect, major)

defect
Not set
major

Tracking

(thunderbird60 fixed, thunderbird61 fixed)

RESOLVED FIXED
Thunderbird 61.0
Tracking Status
thunderbird60 --- fixed
thunderbird61 --- fixed

People

(Reporter: public, Assigned: aceman)

References

Details

(Keywords: regression)

Attachments

(1 file)

Regression of bug 691141: it is no longer possible to cancel the new contact dialog.

STR:
0. Thunderbird 60.0b5 (or current alpha/trunk)
1. Open the address book window
2. Click the new contact button on the toolbar
3. Cancel the dialog

Expected:
The dialog closes

Actual:
The dialog does not close


Reason:
The patch for bug 691141 adds a call to "NewCardCancelButton", which is not defined.

I'd assume the function *should* be identical to EditCardCancelButton and purge temporary contact images.
Aceman, can we fix this in a hurry.
Flags: needinfo?(acelists)
Blocks: 691141
Keywords: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
Good catch, thanks.
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Flags: needinfo?(acelists)
Attached patch 1458384.patchSplinter Review
It seems for now the *CardCancelButton() functions can have the same content, but I do not merge them in case they differ in future. As *CardOKButton() functions do.
Attachment #8972698 - Flags: review?(jorgk)
Comment on attachment 8972698 [details] [diff] [review]
1458384.patch

Works for me.
Attachment #8972698 - Flags: review?(jorgk) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/32c055383e63
Implement missing NewCardCancelButton() in abCard.js to make canceling new card dialog work again. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 61.0
Attachment #8972698 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.